package/coreutils: simplify the [ -> test symlink
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 22 Jun 2019 13:19:36 +0000 (15:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 22 Jun 2019 15:48:43 +0000 (17:48 +0200)
Wheter we are mutli-call or multi-binaries, test is either a symlink to
coreutils or a standalone binary.

Consequently, test always exists, and so we can simplify the [ symlink.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Markus Mayer <mmayer@broadcom.com>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/coreutils/coreutils.mk

index 6b8f3ba4b82fb153fdc04322ae653c3a4913c1e3..55aa92e753e43642d6629264a5f0de4643b297ca 100644 (file)
@@ -130,15 +130,9 @@ COREUTILS_CONF_OPTS += --enable-no-install-program=stdbuf
 endif
 
 # link for archaic shells
-ifeq ($(BR2_PACKAGE_COREUTILS_INDIVIDUAL_BINARIES),y)
 define COREUTILS_CREATE_TEST_SYMLINK
        ln -fs test $(TARGET_DIR)/usr/bin/[
 endef
-else
-define COREUTILS_CREATE_TEST_SYMLINK
-       ln -fs coreutils $(TARGET_DIR)/usr/bin/[
-endef
-endif
 COREUTILS_POST_INSTALL_TARGET_HOOKS += COREUTILS_CREATE_TEST_SYMLINK
 
 # gnu thinks chroot is in bin, debian thinks it's in sbin