package/libtorrent-rasterbar: fix build on m68k_cf
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 14 May 2019 17:02:13 +0000 (19:02 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 15 May 2019 12:20:08 +0000 (14:20 +0200)
An internal compiler error is raised on m68k_cf at dwarf2cfi.c:2802 in
connect_traces. Error can be fixed by adding -fno-defer-pop, see
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=58864

Fixes:
 - http://autobuild.buildroot.org/results/746f60fadb40288341c1e5642cfcf6373b70583a

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libtorrent-rasterbar/libtorrent-rasterbar.mk

index fdcc736b4722d186cfecda1d062002ac30b4fcf8..012e972f1d7832dccce6392f125e41f52fa2c2dd 100644 (file)
@@ -13,7 +13,15 @@ LIBTORRENT_RASTERBAR_INSTALL_STAGING = YES
 LIBTORRENT_RASTERBAR_CONF_OPTS = \
        --with-boost-libdir=$(STAGING_DIR)/usr/lib \
        --disable-invariant-checks
-LIBTORRENT_RASTERBAR_CONF_ENV += CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11"
+LIBTORRENT_RASTERBAR_CXXFLAGS = $(TARGET_CXXFLAGS) -std=c++11
+
+# Internal error, aborting at dwarf2cfi.c:2802 in connect_traces
+# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=58864
+ifeq ($(BR2_m68k_cf),y)
+LIBTORRENT_RASTERBAR_CXXFLAGS += -fno-defer-pop
+endif
+
+LIBTORRENT_RASTERBAR_CONF_OPTS += CXXFLAGS="$(LIBTORRENT_RASTERBAR_CXXFLAGS)"
 
 ifeq ($(BR2_ENABLE_LOCALE)$(BR2_PACKAGE_LIBICONV),y)
 LIBTORRENT_RASTERBAR_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBICONV),libiconv)