toolchain/gcc: fix target-gcc for 4.3.x
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 22 Jan 2009 10:04:30 +0000 (10:04 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 22 Jan 2009 10:04:30 +0000 (10:04 -0000)
Includes are in include-fixed and GCC_LIB_SUBDIR needs to be set like for
the rest of 4.x

toolchain/gcc/gcc-uclibc-4.x.mk

index fdc2fa4a3ee8fd7db990b8af0d3caa1df8f5af3f..d3f4d4389d8aacf3dfce319a94300b451b4d0063 100644 (file)
@@ -484,6 +484,11 @@ else
 GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
 endif
 endif
+GCC_INCLUDE_DIR:=include
+ifeq ($(findstring 4.3,$(GCC_VERSION)),4.3)
+GCC_LIB_SUBDIR=lib/gcc/$(REAL_GNU_TARGET_NAME)/$(GCC_VERSION)
+GCC_INCLUDE_DIR:=include-fixed
+endif
 
 $(TARGET_DIR)/usr/bin/gcc: $(GCC_BUILD_DIR3)/.compiled
        PATH=$(TARGET_PATH) DESTDIR=$(TARGET_DIR) \
@@ -514,10 +519,10 @@ endif
        #rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
        #       $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
        # Work around problem of missing syslimits.h
-       if [ ! -f $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/include/syslimits.h ]; then \
+       if [ ! -f $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/$(GCC_INCLUDE_DIR)/syslimits.h ]; then \
                echo "warning: working around missing syslimits.h"; \
-               cp -f $(STAGING_DIR)/$(GCC_LIB_SUBDIR)/include/syslimits.h \
-                       $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/include/; \
+               cp -f $(STAGING_DIR)/$(GCC_LIB_SUBDIR)/$(GCC_INCLUDE_DIR)/syslimits.h \
+                       $(TARGET_DIR)/usr/$(GCC_LIB_SUBDIR)/$(GCC_INCLUDE_DIR)/; \
        fi
        # Make sure we have 'cc'.
        if [ ! -e $(TARGET_DIR)/usr/bin/cc ]; then \