collectd: add configure hint for pg_config
authorPeter Seiderer <ps.report@gmx.net>
Tue, 10 Mar 2015 22:08:07 +0000 (23:08 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 16 Mar 2015 20:30:06 +0000 (21:30 +0100)
Fixes [1] in case postgresql-devel package is installed on the host:

    libpq . . . . . . . . no (libpq-fe.h not found)
    postgresql  . . . . . no (dependency error)
    configure: error: "Some plugins are missing dependencies - see the summary above for details"

Otherwise fixes the following configure warning:

configure: WARNING: pg_config returned with status 127

[1] http://autobuild.buildroot.net/results/336/336b3e932be245faa04969af960702af672916dc

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/collectd/collectd.mk

index d5802d662eb6f8a5ceb5db0b756039af51244df3..a4b91d6eb2951a48f2e9fe9dffae2da91dade0df 100644 (file)
@@ -139,6 +139,9 @@ endif
 ifeq ($(BR2_PACKAGE_NETSNMP),y)
        COLLECTD_CONF_OPTS += --with-libnetsnmp=$(STAGING_DIR)/usr/bin/net-snmp-config
 endif
+ifeq ($(BR2_PACKAGE_POSTGRESQL),y)
+       COLLECTD_CONF_OPTS += --with-libpq=$(STAGING_DIR)/usr/bin/pg_config
+endif
 ifeq ($(BR2_PACKAGE_YAJL),y)
        COLLECTD_CONF_OPTS += --with-yajl=$(STAGING_DIR)/usr
 endif