ntp: enable/disable sntp support depending on BR2_PACKAGE_NTP_SNTP
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Mon, 19 Jun 2017 14:33:25 +0000 (15:33 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 19 Jun 2017 20:11:10 +0000 (22:11 +0200)
We already have an option for selecting sntp support in ntp that can be
chosen from the menuconfig, and ntp's configure script has a --with-sntp
option (with its --without counterpart) which can be used for disabling
sntp support in ntp. However, we are not using it. This patch will make
use of it.

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ntp/ntp.mk

index 26f58628aad1a68a0719982b3f63ab1ebed9be4b..c70d6e6351c3fac769e53e4d758fbbf3aaf8e285 100644 (file)
@@ -65,6 +65,12 @@ else
 NTP_CONF_OPTS += --disable-SHM
 endif
 
+ifeq ($(BR2_PACKAGE_NTP_SNTP),y)
+NTP_CONF_OPTS += --with-sntp
+else
+NTP_CONF_OPTS += --without-sntp
+endif
+
 NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_NTP_KEYGEN) += util/ntp-keygen
 NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_NTP_WAIT) += scripts/ntp-wait/ntp-wait
 NTP_INSTALL_FILES_$(BR2_PACKAGE_NTP_NTPDATE) += ntpdate/ntpdate