Make target stuff last so it can override everything else
authorEric Andersen <andersen@codepoet.org>
Thu, 17 Feb 2005 03:00:29 +0000 (03:00 -0000)
committerEric Andersen <andersen@codepoet.org>
Thu, 17 Feb 2005 03:00:29 +0000 (03:00 -0000)
Makefile

index dbe5ee8752d42d07dc43bf913d9847e65844d2f8..045aa19ef85161656f4aef0c2c8934f09f38085a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -52,7 +52,6 @@ ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
 TARGETS:=host-sed kernel-headers uclibc-configured binutils gcc uclibc-target-utils
 include toolchain/Makefile.in
 include package/Makefile.in
-include target/Makefile.in
 
 #############################################################
 #
@@ -75,6 +74,9 @@ include toolchain/*/*.mk
 include package/*/*.mk
 include target/*/*.mk
 
+# target stuff is last so it can override anything else
+include target/Makefile.in
+
 TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
 TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS))
 TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))