package/collectd: add capabilities option
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 15 Apr 2020 06:30:07 +0000 (08:30 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 17 Aug 2020 10:15:57 +0000 (12:15 +0200)
capabilities plugin is available since version 5.11.0 and
https://github.com/collectd/collectd/commit/b934f1572cdb54cf485b600546a72dbf9929ba2c

It is currently enabled by default depending on jansson and
libmicrohttpd availability

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Asaf Kahlon <asafka7@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/collectd/Config.in
package/collectd/collectd.mk

index e3e3c5401ff2982b634489506994a3820907915f..ca45130c4d59f8a749e160fdcdb767a6ed0a9586 100644 (file)
@@ -131,6 +131,16 @@ config BR2_PACKAGE_COLLECTD_BIND
        help
          Collects BIND DNS statistics.
 
+config BR2_PACKAGE_COLLECTD_CAPABILITIES
+       bool "capabilities"
+       depends on BR2_aarch64 || BR2_i386 || BR2_x86_64 # dmidecode
+       select BR2_PACKAGE_DMIDECODE # runtime
+       select BR2_PACKAGE_JANSSON
+       select BR2_PACKAGE_LIBMICROHTTPD
+       help
+         Collects selected static platform data using dmidecode and
+         expose it through micro embedded webserver.
+
 config BR2_PACKAGE_COLLECTD_CEPH
        bool "ceph"
        select BR2_PACKAGE_YAJL
index ad79e1cb0b00cfaea6b0ff978505e7a2b0fc75ac..b36975daf0bc936109038e54037731f4e587dafc 100644 (file)
@@ -51,6 +51,7 @@ COLLECTD_CONF_OPTS += \
        $(if $(BR2_PACKAGE_COLLECTD_APCUPS),--enable-apcups,--disable-apcups) \
        $(if $(BR2_PACKAGE_COLLECTD_BATTERY),--enable-battery,--disable-battery) \
        $(if $(BR2_PACKAGE_COLLECTD_BIND),--enable-bind,--disable-bind) \
+       $(if $(BR2_PACKAGE_COLLECTD_CAPABILITIES),--enable-capabilities,--disable-capabilities) \
        $(if $(BR2_PACKAGE_COLLECTD_CEPH),--enable-ceph,--disable-ceph) \
        $(if $(BR2_PACKAGE_COLLECTD_CHRONY),--enable-chrony,--disable-chrony) \
        $(if $(BR2_PACKAGE_COLLECTD_CGROUPS),--enable-cgroups,--disable-cgroups) \
@@ -153,6 +154,7 @@ COLLECTD_DEPENDENCIES = \
        $(if $(BR2_PACKAGE_COLLECTD_AMQP),rabbitmq-c) \
        $(if $(BR2_PACKAGE_COLLECTD_APACHE),libcurl) \
        $(if $(BR2_PACKAGE_COLLECTD_BIND),libcurl libxml2) \
+       $(if $(BR2_PACKAGE_COLLECTD_CAPABILITIES),jansson libmicrohttpd) \
        $(if $(BR2_PACKAGE_COLLECTD_CEPH),yajl) \
        $(if $(BR2_PACKAGE_COLLECTD_CURL),libcurl) \
        $(if $(BR2_PACKAGE_COLLECTD_CURL_JSON),libcurl yajl) \