mongrel2: disable polarssl assembly as we do in the polarssl package
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Fri, 27 Nov 2015 13:54:28 +0000 (13:54 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 27 Nov 2015 18:28:45 +0000 (19:28 +0100)
Fixes:
http://autobuild.buildroot.net/results/a92292a1defd441938d3de6c5049473d520ebc4e/
http://autobuild.buildroot.net/results/f3db555dc29e0e0e87762fcace913853ffe2b176/

mongrel2 bundles polarssl so it has the same problem as the polarssl
with the assembly optimization, so let's use the same solution here.

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/mongrel2/mongrel2.mk

index 0be48327acf780d253ad9a302bff08233df1d20e..d0640c9680ba39efcd26edd019fc2a98bc6f3962 100644 (file)
@@ -13,6 +13,21 @@ MONGREL2_LICENSE = BSD-3c
 MONGREL2_LICENSE_FILES = LICENSE
 MONGREL2_DEPENDENCIES = sqlite zeromq
 
+define MONGREL2_POLARSSL_DISABLE_ASM
+       $(SED) '/^#define POLARSSL_HAVE_ASM/d' $(@D)/src/polarssl/include/polarssl/config.h
+endef
+
+# ARM in thumb mode breaks debugging with asm optimizations
+# Microblaze asm optimizations are broken in general
+# MIPS R6 asm is not yet supported
+ifeq ($(BR2_ENABLE_DEBUG)$(BR2_ARM_INSTRUCTIONS_THUMB)$(BR2_ARM_INSTRUCTIONS_THUMB2),yy)
+MONGREL2_POST_CONFIGURE_HOOKS += MONGREL2_POLARSSL_DISABLE_ASM
+else ifeq ($(BR2_microblaze),y)
+MONGREL2_POST_CONFIGURE_HOOKS += MONGREL2_POLARSSL_DISABLE_ASM
+else ifeq ($(BR2_mips_32r6)$(BR2_mips_64r6),y)
+MONGREL2_POST_CONFIGURE_HOOKS += MONGREL2_POLARSSL_DISABLE_ASM
+endif
+
 define MONGREL2_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE1) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
                PREFIX=/usr all