package: make *-rebuild and *-reconfigure only rebuild the given package
authorJérôme Pouiller <jezz@sysmic.org>
Mon, 13 May 2013 15:25:41 +0000 (17:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 13 Aug 2013 10:04:55 +0000 (12:04 +0200)
Originally, the <pkg>-rebuild and <pkg>-reconfigure targets were meant
to restart the build of the package from a given step (build for
<pkg>-rebuild and configure for <pkg>-reconfigure) and then re-create
the entire root filesystem.

However, further discussion from the community has shown that this is
not really the desired behavior: we instead want <pkg>-rebuild and
<pkg>-reconfigure to only take care of rebuilding the given package,
and not the entire root filesystem.

People willing to rebuild this package and the root filesystem can do:

       make <pkg>-rebuild all

[Thomas P: rewrite commit log, since it's not fixing a bug, but
instead changing what was an intended behavior. ]

Signed-off-by: Jérôme Pouiller <jezz@sysmic.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-generic.mk

index b8eaa98bbb164eb97eccb3163825154d1b3a735a..2e2e66f283800da3d4965f9d2e7eddb586cd36e3 100644 (file)
@@ -435,12 +435,12 @@ endif
                        rm -f $$($(2)_TARGET_INSTALL_IMAGES)
                        rm -f $$($(2)_TARGET_INSTALL_HOST)
 
-$(1)-rebuild:          $(1)-clean-for-rebuild all
+$(1)-rebuild:          $(1)-clean-for-rebuild $(1)
 
 $(1)-clean-for-reconfigure: $(1)-clean-for-rebuild
                        rm -f $$($(2)_TARGET_CONFIGURE)
 
-$(1)-reconfigure:      $(1)-clean-for-reconfigure all
+$(1)-reconfigure:      $(1)-clean-for-reconfigure $(1)
 
 # define the PKG variable for all targets, containing the
 # uppercase package variable prefix