apr: fix runtime tests for cross compile
authorPeter Seiderer <ps.report@gmx.net>
Thu, 17 Jan 2019 19:36:30 +0000 (20:36 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 17 Jan 2019 20:57:39 +0000 (21:57 +0100)
- epoll supported since linux-2.5.44/glibc-2.3.2 (see [1])
 - dup3 supported since linux-2.6.27/glibc-2.9 (see [2])
 - SOCK_CLOEXEC supported on linux (see [3])
 - accept4 suppported since linux-2.6.28/glibc-2.10 (see [4])

Fixes [5] apache runtime failure (#11576)

  [mpm_event:crit] [pid 173:tid 1996214272] (70023)This function has not been
      implemented on this platform: AH00495: Couldn't create a Thread Safe Pollset.
      Is it supported on your platform?Also check system or user limits!
  [:emerg] [pid 173:tid 1996214272] AH00017: Pre-configuration failed, exiting

[1] http://man7.org/linux/man-pages/man7/epoll.7.html
[2] https://linux.die.net/man/2/dup3
[4] https://linux.die.net/man/2/accept4
[5] https://bugs.busybox.net/show_bug.cgi?id=11576

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/apr/apr.mk

index 58b1d86b28451a7a2ff543a841a8ef790f566abb..8f29e57c59af658baaefec94d35dd48c60b80850 100644 (file)
@@ -26,7 +26,12 @@ APR_CONF_ENV = \
        ac_cv_sizeof_pid_t=4 \
        ac_cv_struct_rlimit=yes \
        ac_cv_o_nonblock_inherited=no \
-       apr_cv_mutex_recursive=yes
+       apr_cv_mutex_recursive=yes \
+       apr_cv_epoll=yes \
+       apr_cv_epoll_create1=yes \
+       apr_cv_dup3=yes \
+       apr_cv_sock_cloexec=yes \
+       apr_cv_accept4=yes
 APR_CONFIG_SCRIPTS = apr-1-config
 
 # Doesn't even try to guess when cross compiling