ifupdown-script: send current hostname in DHCP request
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 30 Oct 2018 17:16:14 +0000 (18:16 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 5 Nov 2018 22:20:55 +0000 (23:20 +0100)
For the default (BR2_SYSTEM_DHCP) /etc/network/interfaces handling.

Both the "big" and busybox ifupdown variants pass the hostname argument to
the DHCP client through the shell, so we can use $() to expand to the
current hostname value.

Notice that this may not be handled by all DHCP clients.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Reviewed-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ifupdown-scripts/ifupdown-scripts.mk

index ebc89b38725804bff00eb97450a597756ae09e46..17364aed03b6f0f4b44238ad3e044a07548ed6c8 100644 (file)
@@ -23,6 +23,7 @@ define IFUPDOWN_SCRIPTS_DHCP
                echo "iface $(IFUPDOWN_SCRIPTS_DHCP_IFACE) inet dhcp"; \
                echo "  pre-up /etc/network/nfs_check"; \
                echo "  wait-delay 15"; \
+               echo "  hostname \$$(hostname)"; \
        ) >> $(TARGET_DIR)/etc/network/interfaces
        $(INSTALL) -m 0755 -D $(IFUPDOWN_SCRIPTS_PKGDIR)/nfs_check \
                $(TARGET_DIR)/etc/network/nfs_check