Revert "qt5multimedia: fix build issue with mesa3d w/out xcb"
authorGaël PORTAY <gael.portay@savoirfairelinux.com>
Thu, 1 Mar 2018 21:34:28 +0000 (16:34 -0500)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 1 Apr 2018 21:48:30 +0000 (23:48 +0200)
This reverts commit fadaaabe6f79da130f3e68fca23f12f0ffd6b20f.

Superseded by:

qt5base: fix build issue with mesa3d w/out xcb

Signed-off-by: Gaël PORTAY <gael.portay@savoirfairelinux.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/qt5/qt5multimedia/qt5multimedia.mk

index 041ef49092a44ccb16d84ba031d3d7be2db860bb..6df96bcab460f9034a8fbfd24c3533a679345777 100644 (file)
@@ -34,15 +34,8 @@ ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
 QT5MULTIMEDIA_DEPENDENCIES += alsa-lib
 endif
 
-# The mesa's EGL/eglplatform.h header includes X11 headers unless the flag
-# MESA_EGL_NO_X11_HEADERS is defined. Tell to not include X11 headers if
-# the libxcb is not selected.
-ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_EGL)x$(BR2_PACKAGE_LIBXCB),yx)
-QT5MULTIMEDIA_QMAKEFLAGS += QMAKE_CXXFLAGS+=-DMESA_EGL_NO_X11_HEADERS
-endif
-
 define QT5MULTIMEDIA_CONFIGURE_CMDS
-       (cd $(@D); $(TARGET_MAKE_ENV) $(HOST_DIR)/bin/qmake $(QT5MULTIMEDIA_QMAKEFLAGS))
+       (cd $(@D); $(TARGET_MAKE_ENV) $(HOST_DIR)/bin/qmake)
 endef
 
 define QT5MULTIMEDIA_BUILD_CMDS