projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3a74079
)
tstools: perform shared library linking step using gcc rather than ld
author
Peter Korsgaard
<peter@korsgaard.com>
Tue, 12 Nov 2013 22:12:33 +0000
(23:12 +0100)
committer
Peter Korsgaard
<peter@korsgaard.com>
Tue, 12 Nov 2013 22:12:33 +0000
(23:12 +0100)
Fixes http://autobuild.buildroot.net/results/c45/
c45bbdaff6cff56b5646add38032f29bb5520f16
Using ld directly breaks with certain toolchain configurations.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tstools/tstools.mk
patch
|
blob
|
history
diff --git
a/package/tstools/tstools.mk
b/package/tstools/tstools.mk
index 377cc34f91d17998e598824e60e102269cd0c242..c9ac9f9c3becd6e1ff8b5f90e35512e3dbb34055 100644
(file)
--- a/
package/tstools/tstools.mk
+++ b/
package/tstools/tstools.mk
@@
-10,7
+10,8
@@
TSTOOLS_SOURCE = tstools-$(TSTOOLS_VERSION).tgz
TSTOOLS_LICENSE = MPL v1.1
define TSTOOLS_BUILD_CMDS
- $(TARGET_CONFIGURE_OPTS) $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
+ $(TARGET_CONFIGURE_OPTS) LD="$(TARGET_CC)" $(TARGET_MAKE_ENV) \
+ $(MAKE) -C $(@D)
endef
define TSTOOLS_INSTALL_TARGET_CMDS