bash: always prefix readline
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 1 Mar 2014 17:54:26 +0000 (14:54 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Mar 2014 19:39:35 +0000 (20:39 +0100)
Always prefix the readline directory otherwise autodetection may pick up
the host readline when headers are available and target == host (or are
link-compatible). Fixes:
http://autobuild.buildroot.org/results/44a/44a962623be757143a3d6d37fc6cd14964094f79/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bash/bash.mk

index 401f1f2fbe54755ea80861c0de20a9c3a7a6e889..6c7691ff6cbff1f1edad450ae5632a0b4e4a276a 100644 (file)
@@ -12,6 +12,7 @@ BASH_LICENSE = GPLv3+
 BASH_LICENSE_FILES = COPYING
 
 BASH_CONF_ENV += \
+       ac_cv_rl_prefix="$(STAGING_DIR)" \
        ac_cv_rl_version="$(READLINE_VERSION)" \
        bash_cv_job_control_missing=present \
        bash_cv_sys_named_pipes=present \