package/iproute2: bump to version 4.20.0
authorBaruch Siach <baruch@tkos.co.il>
Tue, 12 Mar 2019 15:55:22 +0000 (17:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 12 Mar 2019 20:35:58 +0000 (21:35 +0100)
Drop upstream patch. Renumber the remaining patch.

Add upstream patch fixing build with musl libc.

Cc: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/iproute2/0001-ss-fix-compilation-under-glibc-2.18.patch [new file with mode: 0644]
package/iproute2/0001-utils.h-provide-fallback-CLOCK_TAI-definition.patch [deleted file]
package/iproute2/0002-f_flower-fix-build-with-musl-libc.patch [new file with mode: 0644]
package/iproute2/0002-ss-fix-compilation-under-glibc-2.18.patch [deleted file]
package/iproute2/iproute2.hash
package/iproute2/iproute2.mk

diff --git a/package/iproute2/0001-ss-fix-compilation-under-glibc-2.18.patch b/package/iproute2/0001-ss-fix-compilation-under-glibc-2.18.patch
new file mode 100644 (file)
index 0000000..b6934f5
--- /dev/null
@@ -0,0 +1,39 @@
+From 9700927a008a803ac119bdf816bdc1baa69d705c Mon Sep 17 00:00:00 2001
+From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
+Date: Wed, 20 Feb 2019 15:41:51 +0100
+Subject: [PATCH] ss: fix compilation under glibc < 2.18
+
+Commit c759116a0b2b6da8df9687b0a40ac69050132c77 introduced support for
+AF_VSOCK. This define is only provided since glibc version 2.18, so
+compilation fails when using older toolchains.
+
+Provide the necessary definitions if needed.
+
+Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
+Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
+---
+ misc/ss.c | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/misc/ss.c b/misc/ss.c
+index 9e821faf..766fdc5f 100644
+--- a/misc/ss.c
++++ b/misc/ss.c
+@@ -51,6 +51,14 @@
+ #include <linux/tipc_netlink.h>
+ #include <linux/tipc_sockets_diag.h>
++/* AF_VSOCK/PF_VSOCK is only provided since glibc 2.18 */
++#ifndef PF_VSOCK
++#define PF_VSOCK 40
++#endif
++#ifndef AF_VSOCK
++#define AF_VSOCK PF_VSOCK
++#endif
++
+ #define MAGIC_SEQ 123456
+ #define BUF_CHUNK (1024 * 1024)
+ #define LEN_ALIGN(x) (((x) + 1) & ~1)
+-- 
+2.19.2
+
diff --git a/package/iproute2/0001-utils.h-provide-fallback-CLOCK_TAI-definition.patch b/package/iproute2/0001-utils.h-provide-fallback-CLOCK_TAI-definition.patch
deleted file mode 100644 (file)
index c89db2b..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From 950bf78adc9a3290ed383eaeef01dee6543cfb97 Mon Sep 17 00:00:00 2001
-From: Peter Korsgaard <peter@korsgaard.com>
-Date: Sat, 27 Oct 2018 17:25:31 +0200
-Subject: [PATCH] utils.h: provide fallback CLOCK_TAI definition
-
-q_{etf,taprio}.c uses CLOCK_TAI, which isn't exposed by glibc < 2.21 or
-uClibc, breaking the build. Provide a fallback definition like it is done
-for IPPROTO_MPLS and others.
-
-Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
----
- include/utils.h | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/include/utils.h b/include/utils.h
-index 258d630e..685d2c1d 100644
---- a/include/utils.h
-+++ b/include/utils.h
-@@ -126,6 +126,10 @@ struct ipx_addr {
- #define IPPROTO_MPLS  137
- #endif
-+#ifndef CLOCK_TAI
-+# define CLOCK_TAI 11
-+#endif
-+
- __u32 get_addr32(const char *name);
- int get_addr_1(inet_prefix *dst, const char *arg, int family);
- int get_prefix_1(inet_prefix *dst, char *arg, int family);
--- 
-2.11.0
-
diff --git a/package/iproute2/0002-f_flower-fix-build-with-musl-libc.patch b/package/iproute2/0002-f_flower-fix-build-with-musl-libc.patch
new file mode 100644 (file)
index 0000000..71b652d
--- /dev/null
@@ -0,0 +1,31 @@
+From 28747146622a49c3e7b5c5b36dc02c6a64124770 Mon Sep 17 00:00:00 2001
+From: Hans Dedecker <dedeckeh@gmail.com>
+Date: Wed, 23 Jan 2019 22:02:31 +0100
+Subject: [PATCH] f_flower: fix build with musl libc
+
+XATTR_SIZE_MAX requires the usage of linux/limits.h; let's include it
+
+Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
+Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
+Signed-off-by: Baruch Siach <baruch@tkos.co.il>
+---
+Upstream status: commit 2874714662
+
+ tc/f_flower.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/tc/f_flower.c b/tc/f_flower.c
+index c563666702b5..9659e894dd1f 100644
+--- a/tc/f_flower.c
++++ b/tc/f_flower.c
+@@ -14,6 +14,7 @@
+ #include <unistd.h>
+ #include <string.h>
+ #include <net/if.h>
++#include <linux/limits.h>
+ #include <linux/if_arp.h>
+ #include <linux/if_ether.h>
+ #include <linux/ip.h>
+-- 
+2.20.1
+
diff --git a/package/iproute2/0002-ss-fix-compilation-under-glibc-2.18.patch b/package/iproute2/0002-ss-fix-compilation-under-glibc-2.18.patch
deleted file mode 100644 (file)
index b6934f5..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-From 9700927a008a803ac119bdf816bdc1baa69d705c Mon Sep 17 00:00:00 2001
-From: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
-Date: Wed, 20 Feb 2019 15:41:51 +0100
-Subject: [PATCH] ss: fix compilation under glibc < 2.18
-
-Commit c759116a0b2b6da8df9687b0a40ac69050132c77 introduced support for
-AF_VSOCK. This define is only provided since glibc version 2.18, so
-compilation fails when using older toolchains.
-
-Provide the necessary definitions if needed.
-
-Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
-Signed-off-by: Stephen Hemminger <stephen@networkplumber.org>
----
- misc/ss.c | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/misc/ss.c b/misc/ss.c
-index 9e821faf..766fdc5f 100644
---- a/misc/ss.c
-+++ b/misc/ss.c
-@@ -51,6 +51,14 @@
- #include <linux/tipc_netlink.h>
- #include <linux/tipc_sockets_diag.h>
-+/* AF_VSOCK/PF_VSOCK is only provided since glibc 2.18 */
-+#ifndef PF_VSOCK
-+#define PF_VSOCK 40
-+#endif
-+#ifndef AF_VSOCK
-+#define AF_VSOCK PF_VSOCK
-+#endif
-+
- #define MAGIC_SEQ 123456
- #define BUF_CHUNK (1024 * 1024)
- #define LEN_ALIGN(x) (((x) + 1) & ~1)
--- 
-2.19.2
-
index 00bd1c646af48bf052b4ae3b7db81bc78e9f0678..28862ce19cf907809012ba39d76ef5366b3e2771 100644 (file)
@@ -1,3 +1,3 @@
 # From https://kernel.org/pub/linux/utils/net/iproute2/sha256sums.asc
-sha256 d9ec5ca1f47d8a85416fa26e7dc1cbf5d067640eb60e90bdc1c7e5bdc6a29984  iproute2-4.19.0.tar.xz
+sha256 c8adaa6a40f888476b23acb283cfa30c0dd55f07b5aa20663ed5ba2ef1f6fda8  iproute2-4.20.0.tar.xz
 sha256 e6d6a009505e345fe949e1310334fcb0747f28dae2856759de102ab66b722cb4        COPYING
index 41d0b2c3d9b6307858b90a6ea5cb32d8c3ce3846..13b1f90f3729420a75daa38bb722ab3f54356acb 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-IPROUTE2_VERSION = 4.19.0
+IPROUTE2_VERSION = 4.20.0
 IPROUTE2_SOURCE = iproute2-$(IPROUTE2_VERSION).tar.xz
 IPROUTE2_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/net/iproute2
 IPROUTE2_DEPENDENCIES = host-bison host-flex host-pkgconf \