firmware-imx: move to the freescale-imx directory
authorHenk Fijnvandraat <h.fijnvandraat@inter.nl.net>
Sun, 26 May 2013 12:08:26 +0000 (12:08 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 29 May 2013 13:29:50 +0000 (15:29 +0200)
This commit moves the firmware-imx package to the newly introduced
freescale-imx/ directory, and uses the new variables provided by
freescale-imx/freescale-imx.mk.

Signed-off-by: Henk Fijnvandraat <h.fijnvandraat@inter.nl.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/firmware-imx/Config.in [deleted file]
package/firmware-imx/firmware-imx.mk [deleted file]
package/freescale-imx/Config.in
package/freescale-imx/firmware-imx/Config.in [new file with mode: 0644]
package/freescale-imx/firmware-imx/firmware-imx.mk [new file with mode: 0644]

index 6e7335b5b1c79f9f8833ee85b6dbb792ddeacae4..ab6df09a951047e09388748eb389dd2a5f732621 100644 (file)
@@ -217,7 +217,6 @@ menu "Hardware handling"
 menu "Misc devices firmwares"
 source "package/am33x-cm3/Config.in"
 source "package/b43-firmware/Config.in"
-source "package/firmware-imx/Config.in"
 source "package/linux-firmware/Config.in"
 source "package/rpi-firmware/Config.in"
 source "package/sunxi-boards/Config.in"
diff --git a/package/firmware-imx/Config.in b/package/firmware-imx/Config.in
deleted file mode 100644 (file)
index dd96d88..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-config BR2_PACKAGE_FIRMWARE_IMX
-       bool "firmware-imx"
-       depends on BR2_arm # Only relevant for i.MX
-       help
-         Firmware blobs for the Freescale i.MX SoCs.
-
-         It contains blobs for Atheros AR6003, SDMA and VPU.
-
-         Note: it also contains a blob for ar3k/30101 but upstream
-         linux-firmware has that as well.
-
-         This library is provided by Freescale as-is and doesn't have
-         an upstream.
diff --git a/package/firmware-imx/firmware-imx.mk b/package/firmware-imx/firmware-imx.mk
deleted file mode 100644 (file)
index 3b43bef..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-#############################################################
-#
-# buildroot makefile for firmware-imx
-#
-#############################################################
-
-FIRMWARE_IMX_VERSION = 12.09.01
-# No official download site from freescale, just this mirror
-FIRMWARE_IMX_SITE = http://download.ossystems.com.br/bsp/freescale/source
-FIRMWARE_IMX_SOURCE = firmware-imx-$(FIRMWARE_IMX_VERSION).bin
-FIRMWARE_IMX_LICENSE = Freescale Semiconductor Software License Agreement, \
-       Atheros license (ath6k)
-FIRMWARE_IMX_LICENSE_FILES = licenses/vpu/EULA licenses/ath6k/AR6102/License.txt
-# This is a legal minefield: the EULA specifies that
-# the Board Support Package includes software and hardware (sic!)
-# for which a separate license is needed...
-FIRMWARE_IMX_REDISTRIBUTE = NO
-
-FIRMWARE_IMX_BLOBS = ath6k sdma vpu
-
-# The archive is a shell-self-extractor of a bzipped tar. It happens
-# to extract in the correct directory (firmware-imx-x.y.z)
-# The --force makes sure it doesn't fail if the source dir already exists.
-# The --auto-accept skips the license check - not needed for us
-# because we have legal-info.
-define FIRMWARE_IMX_EXTRACT_CMDS
-       cd $(BUILD_DIR); \
-       sh $(DL_DIR)/$(FIRMWARE_IMX_SOURCE) --force --auto-accept
-endef
-
-
-define FIRMWARE_IMX_INSTALL_TARGET_CMDS
-       mkdir -p $(TARGET_DIR)/lib/firmware
-       for blobdir in $(FIRMWARE_IMX_BLOBS); do \
-               cp -r $(@D)/firmware/$${blobdir} $(TARGET_DIR)/lib/firmware; \
-       done
-endef
-
-$(eval $(generic-package))
index edc9ab53ff6276845c713ab13e21810bfa0a5f66..840b83b19881f4b9d4b4aedf5df09460c51bbda3 100644 (file)
@@ -2,5 +2,6 @@ menu "Freescale i.MX libraries"
        depends on BR2_arm
 
 source "package/freescale-imx/imx-lib/Config.in"
+source "package/freescale-imx/firmware-imx/Config.in"
 
 endmenu
diff --git a/package/freescale-imx/firmware-imx/Config.in b/package/freescale-imx/firmware-imx/Config.in
new file mode 100644 (file)
index 0000000..dd96d88
--- /dev/null
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_FIRMWARE_IMX
+       bool "firmware-imx"
+       depends on BR2_arm # Only relevant for i.MX
+       help
+         Firmware blobs for the Freescale i.MX SoCs.
+
+         It contains blobs for Atheros AR6003, SDMA and VPU.
+
+         Note: it also contains a blob for ar3k/30101 but upstream
+         linux-firmware has that as well.
+
+         This library is provided by Freescale as-is and doesn't have
+         an upstream.
diff --git a/package/freescale-imx/firmware-imx/firmware-imx.mk b/package/freescale-imx/firmware-imx/firmware-imx.mk
new file mode 100644 (file)
index 0000000..85f8dc2
--- /dev/null
@@ -0,0 +1,38 @@
+#############################################################
+#
+# firmware-imx
+#
+#############################################################
+
+FIRMWARE_IMX_VERSION = $(FREESCALE_IMX_VERSION)
+FIRMWARE_IMX_SITE = $(FREESCALE_IMX_MIRROR_SITE)
+FIRMWARE_IMX_SOURCE = firmware-imx-$(FIRMWARE_IMX_VERSION).bin
+FIRMWARE_IMX_LICENSE = Freescale Semiconductor Software License Agreement, \
+       Atheros license (ath6k)
+FIRMWARE_IMX_LICENSE_FILES = licenses/vpu/EULA licenses/ath6k/AR6102/License.txt
+# This is a legal minefield: the EULA specifies that
+# the Board Support Package includes software and hardware (sic!)
+# for which a separate license is needed...
+FIRMWARE_IMX_REDISTRIBUTE = NO
+
+FIRMWARE_IMX_BLOBS = ath6k sdma vpu
+
+# The archive is a shell-self-extractor of a bzipped tar. It happens
+# to extract in the correct directory (firmware-imx-x.y.z)
+# The --force makes sure it doesn't fail if the source dir already exists.
+# The --auto-accept skips the license check - not needed for us
+# because we have legal-info.
+define FIRMWARE_IMX_EXTRACT_CMDS
+       cd $(BUILD_DIR); \
+       sh $(DL_DIR)/$(FIRMWARE_IMX_SOURCE) --force --auto-accept
+endef
+
+
+define FIRMWARE_IMX_INSTALL_TARGET_CMDS
+       mkdir -p $(TARGET_DIR)/lib/firmware
+       for blobdir in $(FIRMWARE_IMX_BLOBS); do \
+               cp -r $(@D)/firmware/$${blobdir} $(TARGET_DIR)/lib/firmware; \
+       done
+endef
+
+$(eval $(generic-package))