linux/linux-ext-xenomai: allow URL for the ADEOS/IPIPE patch
authorSébastien Szymanski <sebastien.szymanski@armadeus.com>
Fri, 17 May 2019 12:50:49 +0000 (14:50 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 20 May 2019 19:21:42 +0000 (21:21 +0200)
With an URL Buildroot will be able to download the patch
automatically.

Signed-off-by: Sébastien Szymanski <sebastien.szymanski@armadeus.com>
[Thomas: don't strip file:// in the non-download case]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
linux/Config.ext.in
linux/linux-ext-xenomai.mk

index 32dacbdf06be30fc746a547f5cbf1c50ff2da48a..14140d352cd5889a26ceb584b1fac7aec447f5c0 100644 (file)
@@ -22,18 +22,21 @@ config BR2_LINUX_KERNEL_EXT_XENOMAI
 
          However, it is recommended to use the latest version of the
          Adeos/Ipipe patch available at
-         http://download.gna.org/adeos/patches
+         https://xenomai.org/downloads/ipipe/
 
          Xenomai is know to support Blackfin, SH4, x86, ARM, NIOS2
          and PowerPC architectures.
 
 config BR2_LINUX_KERNEL_EXT_XENOMAI_ADEOS_PATCH
-       string "Path for Adeos patch file"
+       string "Path/URL for Adeos patch file"
        depends on BR2_LINUX_KERNEL_EXT_XENOMAI
        help
-         Optionally, explicitly specify the Adeos patch to use.
-         Download it at http://download.gna.org/adeos/patches
-         and verify that your kernel version in buildroot matches.
+         Optionally, explicitly specify where to find the Adeos
+         patch to use.
+         Examples:
+         https://xenomai.org/downloads/ipipe/v4.x/arm/ipipe-core-4.19.33-arm-2.patch
+         or /home/foo/ipipe-core-4.19.33-arm-2.patch
+         Please verify that your kernel version in Buildroot matches.
 
 comment "xenomai needs a uClibc or glibc toolchain w/ threads"
        depends on BR2_PACKAGE_XENOMAI_COBALT_ARCH_SUPPORTS
index d066bb32ac09184bc2b9887d97cab79717b3a9e2..c7c112dac3a1fc4538796ffc75f0f9fa4cad2792 100644 (file)
@@ -8,10 +8,20 @@ LINUX_EXTENSIONS += xenomai
 
 # Adeos patch version
 XENOMAI_ADEOS_PATCH = $(call qstrip,$(BR2_LINUX_KERNEL_EXT_XENOMAI_ADEOS_PATCH))
+
+ifneq ($(filter ftp://% http://% https://%,$(XENOMAI_ADEOS_PATCH)),)
+XENOMAI_ADEOS_PATCH_NAME = $(notdir $(XENOMAI_ADEOS_PATCH))
+XENOMAI_ADEOS_PATCH_PATH = $(LINUX_DL_DIR)/$(XENOMAI_ADEOS_PATCH_NAME)
+LINUX_EXTRA_DOWNLOADS += $(XENOMAI_ADEOS_PATCH)
+BR_NO_CHECK_HASH_FOR += $(XENOMAI_ADEOS_PATCH_NAME)
+else
+XENOMAI_ADEOS_PATCH_PATH = $(XENOMAI_ADEOS_PATCH)
+endif
+
 ifeq ($(XENOMAI_ADEOS_PATCH),)
 XENOMAI_ADEOS_OPTS = --default
 else
-XENOMAI_ADEOS_OPTS = --adeos=$(XENOMAI_ADEOS_PATCH)
+XENOMAI_ADEOS_OPTS = --adeos=$(XENOMAI_ADEOS_PATCH_PATH)
 endif
 
 # Prepare kernel patch