package/dbus: fix group and mode for the launcher
authorNorbert Lange <nolange79@gmail.com>
Fri, 5 Jun 2020 22:52:45 +0000 (00:52 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 6 Jun 2020 20:33:15 +0000 (22:33 +0200)
The D-Bus installation process installs dbus-daemon-launch-helper as
follows:

  chown root:$(DBUS_USER) $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper$(EXEEXT); \
  chmod 4750 $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper$(EXEEXT); \

And when the installation does not take place as root (like is the
case in the context of Buildroot), it prints:

  echo "Not installing $(DESTDIR)$(libexecdir)/dbus-daemon-launch-helper binary setuid!"; \
  echo "You'll need to manually set permissions to root:$(DBUS_USER) and permissions 4750"; \

So let's adjust the installation logic of dbus-daemon-launch-helper to
match these requirements.

Signed-off-by: Norbert Lange <nolange79@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/dbus/dbus.mk

index a4043864d11478259f7176e8c404b71c70fae483..bb9f17a5e0e17a16857b20b7066f4a7c2ee04fa6 100644 (file)
@@ -11,7 +11,7 @@ DBUS_LICENSE_FILES = COPYING
 DBUS_INSTALL_STAGING = YES
 
 define DBUS_PERMISSIONS
-       /usr/libexec/dbus-daemon-launch-helper f 4755 0 0 - - - - -
+       /usr/libexec/dbus-daemon-launch-helper f 4750 0 dbus - - - - -
 endef
 
 define DBUS_USERS