pkg-rebar: add bin to list of install directories
authorFrank Hunleth <fhunleth@troodon-software.com>
Mon, 16 Feb 2015 17:00:29 +0000 (12:00 -0500)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 18 Feb 2015 22:21:01 +0000 (23:21 +0100)
Some Erlang packages provide a bin directory for programs that are to be
invoked from the command line. An example of such a package is the Lisp
Flavored Erlang compiler. The Erlang OTP library includes several more
examples (it doesn't use rebar, though.) This change makes sure that the
bin directory gets installed too.

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-rebar.mk

index 57fb2f44f5b9c7691e93cdbbab47aa9b26da5e07..45d1c7dfc1510f89a0aa079813fa6d49f2a0ab61 100644 (file)
@@ -43,7 +43,7 @@ REBAR_TARGET_DEPS_ENV = \
 
 # Install an Erlang application from $(@D).
 #
-# i.e., define a recipe that installs the "ebin priv $(2)" directories
+# i.e., define a recipe that installs the "bin ebin priv $(2)" directories
 # from $(@D) to $(1)$($(PKG)_ERLANG_LIBDIR).
 #
 #  argument 1 should typically be $(HOST_DIR), $(TARGET_DIR),
@@ -57,7 +57,7 @@ REBAR_TARGET_DEPS_ENV = \
 #
 define install-erlang-directories
        $(INSTALL) -d $(1)/$($(PKG)_ERLANG_LIBDIR)
-       for dir in ebin priv $(2); do                                   \
+       for dir in bin ebin priv $(2); do                               \
                if test -d $(@D)/$$dir; then                            \
                        cp -r $(@D)/$$dir $(1)$($(PKG)_ERLANG_LIBDIR);  \
                fi;                                                     \