ntp: move systemd service file to /usr/lib
authorMike Williams <mike@mikebwilliams.com>
Fri, 20 Mar 2015 19:13:53 +0000 (15:13 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 20 Mar 2015 19:33:12 +0000 (20:33 +0100)
Signed-off-by: Mike Williams <mike@mikebwilliams.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ntp/ntp.mk

index 7d5644a90226827b98c4db3317181f378e631b04..36dea79d32e44b11cdce824abb5a1e74c0d3b811 100644 (file)
@@ -71,9 +71,10 @@ define NTP_INSTALL_INIT_SYSV
 endef
 
 define NTP_INSTALL_INIT_SYSTEMD
-       $(INSTALL) -D -m 644 package/ntp/ntpd.service $(TARGET_DIR)/etc/systemd/system/ntpd.service
+       $(INSTALL) -D -m 644 package/ntp/ntpd.service $(TARGET_DIR)/usr/lib/systemd/system/ntpd.service
        mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
-       ln -fs ../ntpd.service $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/ntpd.service
+       ln -fs ../../../../usr/lib/systemd/system/ntpd.service \
+               $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/ntpd.service
 endef
 endif