unionfs: add patch to disable search for the C++ compiler
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 13 Oct 2012 23:21:43 +0000 (23:21 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 14 Oct 2012 09:38:48 +0000 (11:38 +0200)
Fixes

  http://autobuild.buildroot.org/results/9c4a9897dda1b99cc7a57af605301b53ed32b95d/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/unionfs/unionfs-fuse-no-cxx-needed.patch [new file with mode: 0644]

diff --git a/package/unionfs/unionfs-fuse-no-cxx-needed.patch b/package/unionfs/unionfs-fuse-no-cxx-needed.patch
new file mode 100644 (file)
index 0000000..56f7e24
--- /dev/null
@@ -0,0 +1,19 @@
+By default, CMake assumes a project uses the C and C++ languages, so
+it checks for both the C and the C++ compiler to exist.
+
+However, unionfs-fuse is written purely in C, so checking for a C++
+compiler is useless, and even prevents unionfs-fuse from building
+properly on targets for which no C++ compiler is available.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/CMakeLists.txt
+===================================================================
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1,4 +1,4 @@
+-project(unionfs-fuse)
++project(unionfs-fuse C)
+ cmake_minimum_required(VERSION 2.0)
+ INCLUDE (CheckIncludeFiles)