kbd: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:50:17 +0000 (22:50 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:27:26 +0000 (01:27 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/kbd/Config.in
package/kbd/kbd.mk

index ab1f1b310001c46121408488cd503d9367780b1d..6cf2fc0dc6b17dbfe09e605c2f6fd42cf233a243 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_KBD
        bool "kbd"
        # Uses fork()
        depends on BR2_USE_MMU
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          Keytable files and keyboard utilities.
 
index 175a2374d8d0706e915da524a075995763bbe989..a4873f3a08e4a0385cfba42af9698dbffd434bc6 100644 (file)
@@ -11,7 +11,7 @@ KBD_CONF_OPTS = \
        --disable-vlock \
        --disable-tests
 KBD_DEPENDENCIES = \
-       $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext) \
+       $(TARGET_NLS_DEPENDENCIES) \
        host-pkgconf
 KBD_LICENSE = GPL-2.0+
 KBD_LICENSE_FILES = COPYING