gutenprint: ensure target and host variant have the same patch hooks
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 May 2013 13:01:02 +0000 (13:01 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 30 May 2013 19:54:10 +0000 (21:54 +0200)
In preparation for the out-of-tree support, it is important that all
packages have the same patch hooks for the host variant and the target
variant (because the source tree will be shared between host and
target variants when doing out-of-tree build).

In the case of gutenprint, the patch hook executed for the target just
creates one directory which is needed for autoreconf to work, and the
host variant is not autoreconf'ed. So there is no harm in also
applying this patch hook to the host variant.

[Peter: autoreconf for host as pointed out by Arnout]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gutenprint/gutenprint.mk

index 0463771381b66b09d250cfe4b3e93176eb0affb3..b5d350dfdad165c69af56e187288bde20b2d35df 100644 (file)
@@ -12,6 +12,7 @@ GUTENPRINT_LICENSE_FILES = COPYING
 
 # Needed, as we touch Makefile.am
 GUTENPRINT_AUTORECONF = YES
+HOST_GUTENPRINT_AUTORECONF = YES
 
 GUTENPRINT_DEPENDENCIES = cups host-pkgconf \
        $(if $(BR2_PACKAGE_LIBICONV),libiconv)
@@ -58,6 +59,7 @@ define GUTENPRINT_CREATE_M4_DIR
        mkdir -p $(@D)/m4local
 endef
 GUTENPRINT_POST_PATCH_HOOKS += GUTENPRINT_CREATE_M4_DIR
+HOST_GUTENPRINT_POST_PATCH_HOOKS += GUTENPRINT_CREATE_M4_DIR
 
 define HOST_GUTENPRINT_POST_BUILD_INSTAL_TMP_HEADER
        cp $(@D)/src/xml/xmli18n-tmp.h $(HOST_DIR)/usr/include