package/php-xdebug: new package
authorNicolas Carrier <nicolas.carrier@orolia.com>
Fri, 25 Oct 2019 18:22:49 +0000 (18:22 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 3 Sep 2020 20:10:22 +0000 (22:10 +0200)
Extension for PHP to assist with debugging and development.

Signed-off-by: Nicolas Carrier <nicolas.carrier@orolia.com>
Reviewed-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/php-xdebug/Config.in [new file with mode: 0644]
package/php-xdebug/php-xdebug.hash [new file with mode: 0644]
package/php-xdebug/php-xdebug.mk [new file with mode: 0644]

index 677350a55506f80fe2caa827102cf8a7f173951b..06b2b2f6a682f23ab4f63ab880a1f13998d1566c 100644 (file)
@@ -1916,6 +1916,9 @@ N:        Nicholas Sielicki <sielicki@yandex.com>
 F:     board/intel/galileo/
 F:     configs/galileo_defconfig
 
+N:     Nicolas Carrier <nicolas.carrier@orolia.com>
+F:     package/php-xdebug/
+
 N:     Nicolas Cavallari <nicolas.cavallari@green-communications.fr>
 F:     package/libgit2/
 
index 8c2726b4ceedc27cabd6d5bc044e74437b714eeb..bbbd2a3642fea8ea10e31bc5c662dce4fea7b6e3 100644 (file)
@@ -837,6 +837,7 @@ menu "External php extensions"
        source "package/php-imagick/Config.in"
        source "package/php-memcached/Config.in"
        source "package/php-ssh2/Config.in"
+       source "package/php-xdebug/Config.in"
        source "package/php-yaml/Config.in"
        source "package/php-zmq/Config.in"
 endmenu
diff --git a/package/php-xdebug/Config.in b/package/php-xdebug/Config.in
new file mode 100644 (file)
index 0000000..b5919e0
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PHP_XDEBUG
+       bool "php-xdebug"
+       help
+         Extension for PHP to assist with debugging and development.
+
+         http://xdebug.org
diff --git a/package/php-xdebug/php-xdebug.hash b/package/php-xdebug/php-xdebug.hash
new file mode 100644 (file)
index 0000000..8b90352
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed
+sha256 ef479ee1a3da3f933e0d046ca8cd0c14601f29b2c0c41cc60c9388546a4e0272  LICENSE
+sha256 e330c5ccb77890b06dd7bf093567051450b2438b79fed8e7e6c4834278d46092  php-xdebug-2.9.6.tar.gz
diff --git a/package/php-xdebug/php-xdebug.mk b/package/php-xdebug/php-xdebug.mk
new file mode 100644 (file)
index 0000000..ab6ade4
--- /dev/null
@@ -0,0 +1,28 @@
+################################################################################
+#
+# php-xdebug
+#
+################################################################################
+
+PHP_XDEBUG_VERSION = 2.9.6
+PHP_XDEBUG_SITE = $(call github,xdebug,xdebug,$(PHP_XDEBUG_VERSION))
+PHP_XDEBUG_INSTALL_STAGING = YES
+PHP_XDEBUG_LICENSE = Xdebug License (PHP-3.0-like)
+PHP_XDEBUG_LICENSE_FILES = LICENSE
+# phpize does the autoconf magic
+PHP_XDEBUG_DEPENDENCIES = php host-autoconf
+PHP_XDEBUG_CONF_OPTS = \
+       --enable-xdebug \
+       --with-php-config=$(STAGING_DIR)/usr/bin/php-config \
+       --with-xdebug=$(STAGING_DIR)/usr
+
+define PHP_XDEBUG_PHPIZE
+       (cd $(@D); \
+               PHP_AUTOCONF=$(HOST_DIR)/bin/autoconf \
+               PHP_AUTOHEADER=$(HOST_DIR)/bin/autoheader \
+               $(STAGING_DIR)/usr/bin/phpize)
+endef
+
+PHP_XDEBUG_PRE_CONFIGURE_HOOKS += PHP_XDEBUG_PHPIZE
+
+$(eval $(autotools-package))