fs/ext2: fix typo
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 19 Apr 2010 09:03:45 +0000 (11:03 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 19 Apr 2010 09:03:45 +0000 (11:03 +0200)
BR2_TARGET_ROOTFS_EXT2_RESBLKS is an int, so test against 0 rather than
the empty string - Otherwise the test is always true and a -m option
without arguments is added to the argument list, causing genext2fs to
get confused.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
fs/ext2/ext2.mk

index 68b3b813c36f02972ca524f2a8310bd5e678b3be..f3d3ff92fe088fab4f0be253d8ee4f5d2981dd8c 100644 (file)
@@ -18,7 +18,7 @@ ifneq ($(strip $(BR2_TARGET_ROOTFS_EXT2_INODES)),0)
 EXT2_OPTS += -N $(BR2_TARGET_ROOTFS_EXT2_INODES)
 endif
 
-ifneq ($(strip $(BR2_TARGET_ROOTFS_EXT2_RESBLKS)),)
+ifneq ($(strip $(BR2_TARGET_ROOTFS_EXT2_RESBLKS)),0)
 EXT2_OPTS += -m $(BR2_TARGET_ROOTFS_EXT2_RESBLKS)
 endif