uboot-mkimage: use correct host compiler/flags
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 10 Jul 2011 19:59:54 +0000 (21:59 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 10 Jul 2011 19:59:54 +0000 (21:59 +0200)
As used elswwhere in BR.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/uboot-mkimage/uboot-mkimage-2011.03-hostcflags-override-fix.patch [new file with mode: 0644]
package/uboot-mkimage/uboot-mkimage.mk

diff --git a/package/uboot-mkimage/uboot-mkimage-2011.03-hostcflags-override-fix.patch b/package/uboot-mkimage/uboot-mkimage-2011.03-hostcflags-override-fix.patch
new file mode 100644 (file)
index 0000000..0202eda
--- /dev/null
@@ -0,0 +1,29 @@
+[PATCH] Fix tools build with custom HOSTCFLAGS
+
+We always need to append HOSTCPPFLAGS, even if HOSTCFLAGS have been
+overridden on the cmdline.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ config.mk |    6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+Index: u-boot-2011.03/config.mk
+===================================================================
+--- u-boot-2011.03.orig/config.mk
++++ u-boot-2011.03/config.mk
+@@ -46,10 +46,12 @@
+ #########################################################################
+-HOSTCFLAGS    = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer \
+-                $(HOSTCPPFLAGS)
++HOSTCFLAGS    = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
+ HOSTSTRIP     = strip
++# append CPPFLAGS even if CFLAGS has been overridden on cmdline
++override HOSTCFLAGS += $(HOSTCPPFLAGS)
++
+ #
+ # Mac OS X / Darwin's C preprocessor is Apple specific.  It
+ # generates numerous errors and warnings.  We want to bypass it
index 055348c3cb10b0244f2a9e7ea34f67e483f436ee..b8f2ee5de7dd81f5a846951573a47944a6291e51 100644 (file)
@@ -4,8 +4,9 @@ UBOOT_MKIMAGE_SITE    = ftp://ftp.denx.de/pub/u-boot
 
 define HOST_UBOOT_MKIMAGE_BUILD_CMDS
        $(MAKE) -C $(@D)                        \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
-               ARCH=$(U_BOOT_ARCH)             \
+               HOSTCC="$(HOSTCC)"              \
+               HOSTCFLAGS="$(HOST_CFLAGS)"     \
+               HOSTLDFLAGS="$(HOST_LDFLAGS)"   \
                tools
 endef