package/python-regex: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Mon, 23 Mar 2020 10:49:03 +0000 (11:49 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 24 Apr 2020 12:48:31 +0000 (14:48 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/Config.in
package/python-regex/Config.in [new file with mode: 0644]
package/python-regex/python-regex.hash [new file with mode: 0644]
package/python-regex/python-regex.mk [new file with mode: 0644]

index a9c6f6fcbca6c1d99e97b9a0dfbd38622c9600da..9a6461277e98dacbc7d2eac4ba54c011636dcf20 100644 (file)
@@ -1118,6 +1118,7 @@ menu "External python modules"
        source "package/python-raven/Config.in"
        source "package/python-redis/Config.in"
        source "package/python-reentry/Config.in"
+       source "package/python-regex/Config.in"
        source "package/python-remi/Config.in"
        source "package/python-request-id/Config.in"
        source "package/python-requests/Config.in"
diff --git a/package/python-regex/Config.in b/package/python-regex/Config.in
new file mode 100644 (file)
index 0000000..5f582d0
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_REGEX
+       bool "python-regex"
+       help
+         Alternative regular expression module, to replace re.
+
+         https://bitbucket.org/mrabarnett/mrab-regex
diff --git a/package/python-regex/python-regex.hash b/package/python-regex/python-regex.hash
new file mode 100644 (file)
index 0000000..9e25626
--- /dev/null
@@ -0,0 +1,3 @@
+# md5, sha256 from https://pypi.org/pypi/regex/json
+md5  ac88a9c036e626ae4d436e69f35f50cf  regex-2020.2.20.tar.gz
+sha256  9e9624440d754733eddbcd4614378c18713d2d9d0dc647cf9c72f64e39671be5  regex-2020.2.20.tar.gz
diff --git a/package/python-regex/python-regex.mk b/package/python-regex/python-regex.mk
new file mode 100644 (file)
index 0000000..aea967c
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-regex
+#
+################################################################################
+
+PYTHON_REGEX_VERSION = 2020.2.20
+PYTHON_REGEX_SOURCE = regex-$(PYTHON_REGEX_VERSION).tar.gz
+PYTHON_REGEX_SITE = https://files.pythonhosted.org/packages/e8/76/8ac7f467617b9cfbafcef3c76df6f22b15de654a62bea719792b00a83195
+PYTHON_REGEX_SETUP_TYPE = setuptools
+PYTHON_REGEX_LICENSE = CNRI-Python
+
+$(eval $(python-package))