libedbus: Add new package
authorWill Newton <will.newton@gmail.com>
Thu, 26 Jan 2012 17:42:59 +0000 (17:42 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 29 Jan 2012 22:20:32 +0000 (23:20 +0100)
[Peter: select dbus, add upstream URL, remove unneeded autoreconf]
Signed-off-by: Will Newton <will.newton@imgtec.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/efl/Config.in
package/efl/libedbus/Config.in [new file with mode: 0644]
package/efl/libedbus/libedbus.mk [new file with mode: 0644]

index ec8c5137c7479ff35fe3d05fd490cedc87e3675f..c783d7f078f919d669db65d15c18612b9ca577cf 100644 (file)
@@ -18,6 +18,7 @@ source "package/efl/libembryo/Config.in"
 source "package/efl/libedje/Config.in"
 source "package/efl/libethumb/Config.in"
 source "package/efl/libelementary/Config.in"
+source "package/efl/libedbus/Config.in"
 
 endif # BR2_PACKAGE_EFL
 
diff --git a/package/efl/libedbus/Config.in b/package/efl/libedbus/Config.in
new file mode 100644 (file)
index 0000000..3844b52
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBEDBUS
+       bool "libedbus"
+       select BR2_PACKAGE_LIBEINA
+       select BR2_PACKAGE_LIBECORE
+       depends on BR2_PACKAGE_DBUS
+       help
+         E_Dbus is a set of wrappers around D-Bus APIs so they can be
+         easily used by EFL applications, automatically providing
+         Ecore/main loop integration, as well as Eina data types.
+
+         http://trac.enlightenment.org/e/wiki/E_Dbus
diff --git a/package/efl/libedbus/libedbus.mk b/package/efl/libedbus/libedbus.mk
new file mode 100644 (file)
index 0000000..34f34a7
--- /dev/null
@@ -0,0 +1,14 @@
+#############################################################
+#
+# libedbus
+#
+#############################################################
+
+LIBEDBUS_VERSION = 1.1.0
+LIBEDBUS_SOURCE = e_dbus-$(LIBEDBUS_VERSION).tar.bz2
+LIBEDBUS_SITE = http://download.enlightenment.org/releases/
+LIBEDBUS_INSTALL_STAGING = YES
+
+LIBEDBUS_DEPENDENCIES = host-pkg-config dbus libeina libecore
+
+$(eval $(call AUTOTARGETS))