package/sawman: Add Package SawMan
authorDaniel Laird <danieljlaird@hotmail.com>
Thu, 16 Oct 2008 12:10:23 +0000 (12:10 -0000)
committerDaniel Laird <danieljlaird@hotmail.com>
Thu, 16 Oct 2008 12:10:23 +0000 (12:10 -0000)
SaWMan is a new window manager module for use with DirectFB.
Its main difference to the default module is that it allows one process
to be an application and window manager,
implementing all kinds of diversity,
while SaWMan is only the working horse.

Daniel Laird

package/Config.in
package/sawman/Config.in [new file with mode: 0644]
package/sawman/sawman.mk [new file with mode: 0644]

index bc5e62044548c3e8a5c8ec8a597ca763ad873530..7507ec15ef4f6e9a9d9ec4c593392f2fc28696ff 100644 (file)
@@ -318,6 +318,7 @@ source "package/libpng/Config.in"
 source "package/libungif/Config.in"
 source "package/lite/Config.in"
 source "package/pixman/Config.in"
+source "package/sawman/Config.in"
 source "package/sdl/Config.in"
 source "package/sdl_image/Config.in"
 source "package/sdl_mixer/Config.in"
diff --git a/package/sawman/Config.in b/package/sawman/Config.in
new file mode 100644 (file)
index 0000000..8dd3ace
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_SAWMAN
+       bool "SawMan (Window Manager)"
+       depends on BR2_PACKAGE_DIRECTFB
+       help
+         SaWMan is a new window manager module for use with DirectFB. 
+          Its main difference to the default module is that it allows 
+          one process to be an application and window manager, 
+          implementing all kinds of diversity, while SaWMan is only the 
+          working horse.
+
+          See http://www.directfb.org/downloads/Extras/README.SaWMan
+
diff --git a/package/sawman/sawman.mk b/package/sawman/sawman.mk
new file mode 100644 (file)
index 0000000..4956878
--- /dev/null
@@ -0,0 +1,16 @@
+#############################################################
+#
+# SAWMAN
+#
+#############################################################
+SAWMAN_VERSION:=1.2.0-rc1
+SAWMAN_SOURCE:=SaWMan-$(SAWMAN_VERSION).tar.gz
+SAWMAN_SITE:=http://www.directfb.org/downloads/Extras
+SAWMAN_INSTALL_STAGING = YES
+SAWMAN_INSTALL_TARGET = YES
+SAWMAN_CONF_ENV = LDFLAGS="-L$(STAGING_DIR)/usr/lib -Wl,--rpath-link -Wl,$(STAGING_DIR)/usr/lib"
+SAWMAN_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) LDFLAGS=-L$(STAGING_DIR)/usr/lib install-strip
+SAWMAN_DEPENDENCIES = directfb
+
+$(eval $(call AUTOTARGETS,package,sawman))
+