psmisc: bump version and fix build
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 23 Nov 2009 13:41:36 +0000 (14:41 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 23 Nov 2009 13:41:36 +0000 (14:41 +0100)
./configure in psmisc 22.6 tested for a working C++ compiler and errored out
if not found, even though psmisc doesn't need it - Fixed in 22.8.

pstree.c uses __progname for pstree.x11 support, which isn't (per default)
available in uclibc. This stuff isn't really critical, so just disable it.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/psmisc/psmisc-no-__progname.patch [new file with mode: 0644]
package/psmisc/psmisc.mk

diff --git a/CHANGES b/CHANGES
index 43993a748fef4cc06b6a3eb81099f5c6a5dba47f..b620a1b13baf6351b62593860cbdaa8cf82c28be 100644 (file)
--- a/CHANGES
+++ b/CHANGES
        libelf, libevent, libglib2, libidn, liblockfile, libmad, libpcap,
        libupnp, libuuid, libxml2, lighttpd, ltrace, lua, lzma, magiccube4d,
        matchbox, mdadm, nbd, ncftp, ncurses, netkittelnet, netsnmp,
-       ng-spice-rework, ntfs-3g, openntp, openssl, pcmanfm, php, python,
-       quagga, radvd, rsync, rubix, samba, sawman, sdl, shared-mime-info,
-       spawn-fcgi, speech-tools, sqlite, squashfs, synergy, syslinux,
-       target-binutils, tcpdump, u-boot, util-linux, valgrind, vsftpd, wipe,
-       wpa-supplicant, xdata_xcursor-themes, xboard, xstroke, zlib
+       ng-spice-rework, ntfs-3g, openntp, openssl, pcmanfm, php, psmisc,
+       python, quagga, radvd, rsync, rubix, samba, sawman, sdl,
+       shared-mime-info, spawn-fcgi, speech-tools, sqlite, squashfs, synergy,
+       syslinux, target-binutils, tcpdump, u-boot, util-linux, valgrind,
+       vsftpd, wipe, wpa-supplicant, xdata_xcursor-themes, xboard, xstroke,
+       zlib
 
        Removed package: mdnsresponder, mpatrol, gcc 3.4.6 + 4.0.4, vice
 
diff --git a/package/psmisc/psmisc-no-__progname.patch b/package/psmisc/psmisc-no-__progname.patch
new file mode 100644 (file)
index 0000000..82e6daf
--- /dev/null
@@ -0,0 +1,24 @@
+[PATCH]: pstree: don't use glibc-specific __progname
+
+uclibc (per default) doesn't implement __progname, and the pstree.x11
+stuff isn't that critical, so just disable it.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ src/pstree.c |    3 ---
+ 1 file changed, 3 deletions(-)
+
+Index: psmisc-22.8/src/pstree.c
+===================================================================
+--- psmisc-22.8.orig/src/pstree.c
++++ psmisc-22.8/src/pstree.c
+@@ -893,9 +893,6 @@ main (int argc, char **argv)
+   bindtextdomain(PACKAGE, LOCALEDIR);
+   textdomain(PACKAGE);
+ #endif
+-  
+-  if (!strcmp(__progname, "pstree.x11"))
+-    wait_end=1;
+   /*
+    * Attempt to figure out a good default symbol set.  Will be overriden by
index 90a5186dd0fb4493f0bde43614683db828694ba2..9276b0845533e0dcb207d75f4ae95c89a77db680 100644 (file)
@@ -3,11 +3,11 @@
 # psmisc
 #
 #############################################################
-PSMISC_VERSION:=22.6
+PSMISC_VERSION:=22.8
 PSMISC_SOURCE:=psmisc-$(PSMISC_VERSION).tar.gz
 PSMISC_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/psmisc
-PSMISC_AUTORECONF:=no
-PSMISC_INSTALL_STAGING:=no
+PSMISC_AUTORECONF:=NO
+PSMISC_INSTALL_STAGING:=NO
 PSMISC_INSTALL_TARGET:=YES
 PSMISC_CONF_ENV:=ac_cv_func_malloc_0_nonnull=yes \
                 ac_cv_func_realloc_0_nonnull=yes