package/erlang-p1-xmpp: bump version to 1.4.10
authorJohan Oudinet <johan.oudinet@gmail.com>
Thu, 26 Nov 2020 17:43:00 +0000 (18:43 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 1 Dec 2020 22:24:34 +0000 (23:24 +0100)
upstream uses include_lib. Adapt the corresponding patch accordingly.

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/erlang-p1-xmpp/0001-fix-includes.patch
package/erlang-p1-xmpp/erlang-p1-xmpp.hash
package/erlang-p1-xmpp/erlang-p1-xmpp.mk

index d0a267b721165aa96446159c081cab8b3847d717..f02037fdc1c8135cea9f6c82470d56c196363129 100644 (file)
@@ -6,11 +6,11 @@ diff --git a/include/xmpp.hrl b/include/xmpp.hrl
 index afa5f61..678858e 100644
 --- a/include/xmpp.hrl
 +++ b/include/xmpp.hrl
-@@ -26,7 +26,7 @@
+@@ -25,7 +25,7 @@
  -include("ns.hrl").
  -include("jid.hrl").
  -include("xmpp_codec.hrl").
---include("fxml.hrl").
+--include_lib("fast_xml/include/fxml.hrl").
 +-include_lib("p1_xml/include/fxml.hrl").
 
  -type stanza() :: iq() | presence() | message().
index 05578f99395aa84bcb2e9fb66569eca7a8b0d8ab..d0a761fcac1f98851f964f4b2466ed06ff7dbc39 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated
-sha256 a192349e256c0c0af46e6d7f46c52e6345e61984a266696bb0346934c434f342 erlang-p1-xmpp-1.4.2.tar.gz
-sha256 cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30 LICENSE.txt
+sha256  65c73ffaf8faab5d6fc7d42ada0b5a380f20f3e46056ad98614d81922322d9a2  erlang-p1-xmpp-1.4.10.tar.gz
+sha256  cfc7749b96f63bd31c3c42b5c471bf756814053e847c10f3eb003417bc523d30  LICENSE.txt
index 2f74c60df272ec7a3797f285b901be4ce81098d9..f903cb945dc5b2cc0682a2d43973a05ad9800668 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-ERLANG_P1_XMPP_VERSION = 1.4.2
+ERLANG_P1_XMPP_VERSION = 1.4.10
 ERLANG_P1_XMPP_SITE = $(call github,processone,xmpp,$(ERLANG_P1_XMPP_VERSION))
 ERLANG_P1_XMPP_LICENSE = Apache-2.0
 ERLANG_P1_XMPP_LICENSE_FILES = LICENSE.txt