package/sqlite: bump version to 3.30.0
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 6 Oct 2019 09:22:31 +0000 (11:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 7 Oct 2019 19:45:32 +0000 (21:45 +0200)
Release notes: https://www.sqlite.org/releaselog/3_30_0.html

Changed Config.in option from stat3 to stat4
https://www.sqlite.org/compile.html#enable_stat3
"This option used to cause the ANALYZE command to collect index
 histogram data in the sqlite_stat3 table. But that functionality was
 superceded by SQLITE_ENABLE_STAT4 as of SQLite version 3.8.1
 (2013-10-17). The SQLITE_ENABLE_STAT3 compile-time option continued to
 be supported through version 3.29.0 (2019-07-10) but has now become a
 no-op."

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in.legacy
package/sqlite/Config.in
package/sqlite/sqlite.hash
package/sqlite/sqlite.mk

index e06ba2783bf42396bb59b85262bab8d4ad9dcc4b..4a670f0f0e48184c5c655cf2595007e55da9ad22 100644 (file)
@@ -146,6 +146,12 @@ endif
 
 comment "Legacy options removed in 2019.11"
 
+config BR2_PACKAGE_SQLITE_STAT3
+       bool "sqlite stat3 support was removed"
+       select BR2_LEGACY
+       help
+         Upstream removed the support for stat3.
+
 config BR2_KERNEL_HEADERS_5_1
        bool "kernel headers version 5.1.x are no longer supported"
        select BR2_LEGACY
index 517af50e679e5563fe9a5ed21103654f2688edc5..87c0f6c073a3df14133770a3ce1cd64c1e968314 100644 (file)
@@ -9,8 +9,8 @@ config BR2_PACKAGE_SQLITE
 
 if BR2_PACKAGE_SQLITE
 
-config BR2_PACKAGE_SQLITE_STAT3
-       bool "Additional query optimizations (stat3)"
+config BR2_PACKAGE_SQLITE_STAT4
+       bool "Additional query optimizations (stat4)"
        help
          Adds additional logic to the ANALYZE command and to the
          query planner that can help SQLite to choose a better query
index 649bfba58ec5fe56c677e1c564cf68524e707d46..e297ce3342ce9e45de0a6d93e91b23cb9a205c96 100644 (file)
@@ -1,6 +1,6 @@
 # From https://www.sqlite.org/download.html
-sha1 053d8237eb9741b0e297073810668c2611a8e38e  sqlite-autoconf-3290000.tar.gz
+sha1 785c0f6f00fe1871cb1dd97893267cb50db03b9b  sqlite-autoconf-3300000.tar.gz
 # Calculated based on the hash above
-sha256 8e7c1e2950b5b04c5944a981cb31fffbf9d2ddda939d536838ebc854481afd5b  sqlite-autoconf-3290000.tar.gz
+sha256 e0a8cf4c7a87455e55e10413d16f358ca121ccec687fe1301eac95e2d340fc58  sqlite-autoconf-3300000.tar.gz
 # Locally calculated
 sha256 66e056b6e8687f32af30d5187611b98b12a8f46f07aaf62f43585f276e8f0ac9  tea/license.terms
index 9bd196aaef0159e6f965e4ede4362a2028fb4b41..ba5b5c5d00082e0e8be332e3151cc594dec83978 100644 (file)
@@ -4,15 +4,15 @@
 #
 ################################################################################
 
-SQLITE_VERSION = 3290000
+SQLITE_VERSION = 3300000
 SQLITE_SOURCE = sqlite-autoconf-$(SQLITE_VERSION).tar.gz
 SQLITE_SITE = https://www.sqlite.org/2019
 SQLITE_LICENSE = Public domain
 SQLITE_LICENSE_FILES = tea/license.terms
 SQLITE_INSTALL_STAGING = YES
 
-ifeq ($(BR2_PACKAGE_SQLITE_STAT3),y)
-SQLITE_CFLAGS += -DSQLITE_ENABLE_STAT3
+ifeq ($(BR2_PACKAGE_SQLITE_STAT4),y)
+SQLITE_CFLAGS += -DSQLITE_ENABLE_STAT4
 endif
 
 ifeq ($(BR2_PACKAGE_SQLITE_ENABLE_COLUMN_METADATA),y)