- don't bail out on cc warnings
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 26 Jun 2007 14:32:10 +0000 (14:32 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 26 Jun 2007 14:32:10 +0000 (14:32 -0000)
toolchain/gdb/gdb.mk

index ab9de4e0b2a513754b171ecc87495ee653b32c72..80d66f24c3fbf40a3481aff9cdc0a7cae42d2e2a 100644 (file)
@@ -75,8 +75,8 @@ $(GDB_TARGET_DIR)/.configured: $(GDB_DIR)/.unpacked
        (cd $(GDB_TARGET_DIR); rm -rf config.cache ; \
                gdb_cv_func_sigsetjmp=yes \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS_FOR_TARGET="$(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
-               CFLAGS="$(TARGET_CFLAGS) $(TARGET_LDFLAGS)" \
+               CFLAGS_FOR_TARGET="$(TARGET_CFLAGS) $(TARGET_LDFLAGS) -Wno-error" \
+               CFLAGS="$(TARGET_CFLAGS) $(TARGET_LDFLAGS) -Wno-error" \
                $(GDB_TARGET_CONFIGURE_VARS) \
                $(GDB_DIR)/configure \
                --build=$(GNU_HOST_NAME) \
@@ -88,6 +88,7 @@ $(GDB_TARGET_DIR)/.configured: $(GDB_DIR)/.unpacked
                --disable-tui --disable-gdbtk --without-x \
                --disable-sim --enable-gdbserver \
                --without-included-gettext \
+               --disable-werror \
        );
 ifeq ($(BR2_ENABLE_LOCALE),y)
        -$(SED) "s,^INTL *=.*,INTL = -lintl,g;" $(GDB_DIR)/gdb/Makefile