external-toolchain: add Sourcery CodeBench ARM 2012.03
authorFabio Porcedda <fabio.porcedda@gmail.com>
Mon, 10 Sep 2012 00:02:57 +0000 (00:02 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 29 Sep 2012 07:56:26 +0000 (09:56 +0200)
Signed-off-by: Fabio Porcedda <fabio.porcedda@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/Config.in
toolchain/toolchain-external/ext-tool.mk

index 85b8843e281a7850194377ca4f2fe9a6bc34491d..94ae73521960f6c06957d7fbb38645674cd9a277 100644 (file)
@@ -83,6 +83,27 @@ config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_05
 
          To use this toolchain, you must disable soft float usage.
 
+config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
+       bool "Sourcery CodeBench ARM 2012.03"
+       depends on BR2_arm
+       select BR2_TOOLCHAIN_EXTERNAL_GLIBC
+       select BR2_INSTALL_LIBSTDCPP
+       help
+         Sourcery CodeBench toolchain for the ARM architecture, from
+         Mentor Graphics. It uses gcc 4.6.3, binutils 2.21.53, glibc
+         2.15 and gdb 7.2.50, kernel headers 3.2.10. It has support
+         for the following variants:
+           - ARMv5TE, little endian, soft-float, glibc
+             Select ARM926T, ARM10T, XScale or another ARMv5 core
+             Select BR2_SOFT_FLOAT
+           - ARMv4T, little endian, soft-float, glibc
+             Select ARM720T, ARM920T, ARM922T or another ARMv4 core
+             Select BR2_SOFT_FLOAT
+           - ARMv7-A, Thumb 2, little endian, soft-float, glibc
+             Select Cortex-A8, Cortex-A9 or another ARMv7-A core
+             Select BR2_SOFT_FLOAT
+             Set BR2_TARGET_OPTIMIZATION to -mthumb
+
 config BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
        bool "Sourcery CodeBench ARM 2011.09"
        depends on BR2_arm
@@ -620,6 +641,7 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201009
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103
        default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
+       default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
        default "microblazeel-unknown-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEEL_V2
        default "microblaze-unknown-linux-gnu" if BR2_TOOLCHAIN_EXTERNAL_XILINX_MICROBLAZEBE_V2
        default "mips-linux-gnu"         if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44
index 5a7c03e7670c80958cb4125257ca7734f5d77fc6..43d747cad6d42b90d64b5f0aa8fa0c1377d913ba 100644 (file)
@@ -187,6 +187,9 @@ TOOLCHAIN_EXTERNAL_SOURCE=arm-2011.03-41-arm-none-linux-gnueabi-i686-pc-linux-gn
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109),y)
 TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/arm-none-linux-gnueabi/
 TOOLCHAIN_EXTERNAL_SOURCE=arm-2011.09-70-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203),y)
+TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/public/gnu_toolchain/arm-none-linux-gnueabi/
+TOOLCHAIN_EXTERNAL_SOURCE=arm-2012.03-57-arm-none-linux-gnueabi-i686-pc-linux-gnu.tar.bz2
 else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_05),y)
 TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.05/+download/
 TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.05-20120523_linux.tar.bz2