Patch from acmay: http://bugs.uclibc.org/view.php?id=50
authorEric Andersen <andersen@codepoet.org>
Sun, 23 Jan 2005 11:09:40 +0000 (11:09 -0000)
committerEric Andersen <andersen@codepoet.org>
Sun, 23 Jan 2005 11:09:40 +0000 (11:09 -0000)
0000050: gdb_server and gdb_client fixes and split

Here is a patch with 2 issues.

gdbserver does not depend on ncurses (just the full gdb needs it)

Split out gdb client config option, to be separate from gdbserver.  If you
build gdb client for the host once it does not need to be rebuilt when the rest
of libs change. So I build it and save it off.

toolchain/gdb/Config.in
toolchain/gdb/Makefile.in
toolchain/gdb/gdb.mk

index a17b736dc6f93b9ecd77baea0913fec14db2c277..3bf445ef3fcf1fe9f239411d0ce4a6d42655a7a3 100644 (file)
@@ -1,7 +1,3 @@
-# Choose gcc version.
-# WARNING -- 2.95 currently only builds for i386, arm, mips*, and powerpc.
-# WARNING -- 2.95 does not currently build natively for the target.
-
 comment "Gdb Options"
 
 config BR2_PACKAGE_GDB
@@ -9,14 +5,20 @@ config BR2_PACKAGE_GDB
        default n
        select BR2_PACKAGE_NCURSES
        help
-           Enable the gdb debugger.
+           Build the full gdb debugger to run on the target.
 
 config BR2_PACKAGE_GDB_SERVER
        bool "Build gdb server for the Target"
        default n
-       select BR2_PACKAGE_NCURSES
        help
-           Enable the gdb debugger.
+           Build the gdbserver stub to run on the target.
+           A full gdb is needed to debug the progam.
+
+config BR2_PACKAGE_GDB_CLIENT
+       bool "Build gdb client for the Host"
+       default n
+       help
+           Build gdb to run on the host to debug programs running on the target.
 
 choice
        prompt "GDB debuger Version"
index 51a2ddb3d067af4815d475688c5a9b1be0c65251..50828d86fb692011e3a9fdbd6413df0ba35f964a 100644 (file)
@@ -6,5 +6,9 @@ TARGETS+=gdb_target
 endif
 
 ifeq ($(strip $(BR2_PACKAGE_GDB_SERVER)),y)
-TARGETS+=gdbserver gdbclient
+TARGETS+=gdbserver
+endif
+
+ifeq ($(strip $(BR2_PACKAGE_GDB_CLIENT)),y)
+TARGETS+=gdbclient
 endif
index 862f84d7f52c4cf3f1db1ba127e052043a2449d7..7c3c8deaa7126313a6c45b6453d853ced7f9ee8b 100644 (file)
@@ -135,7 +135,7 @@ $(GDB_SERVER_DIR)/gdbserver: $(GDB_SERVER_DIR)/.configured
 $(TARGET_DIR)/usr/bin/gdbserver: $(GDB_SERVER_DIR)/gdbserver
        install -c $(GDB_SERVER_DIR)/gdbserver $(TARGET_DIR)/usr/bin/gdbserver
 
-gdbserver: ncurses-headers $(TARGET_DIR)/usr/bin/gdbserver
+gdbserver: $(TARGET_DIR)/usr/bin/gdbserver
 
 gdbserver-clean:
        $(MAKE) -C $(GDB_SERVER_DIR) clean