imx-m4fwloader: new package
authorGary Bisson <gary.bisson@boundarydevices.com>
Wed, 24 Jan 2018 17:10:50 +0000 (18:10 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 28 Jan 2018 08:53:44 +0000 (09:53 +0100)
This package provides a tool to load a firmware to the Cortex-M4 core
available in some i.MX processors such as i.MX6SX or i.MX7.

This package was tested on a i.MX7D Nitrogen7 platform:
 # imx-m4fwloader hello_world.bin 0x007F8000

Upstream repository:
https://github.com/codeauroraforum/imx-m4fwloader

[Peter: add license hash, install in /usr/sbin, tweak help text]
Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/freescale-imx/Config.in
package/freescale-imx/imx-m4fwloader/Config.in [new file with mode: 0644]
package/freescale-imx/imx-m4fwloader/imx-m4fwloader.hash [new file with mode: 0644]
package/freescale-imx/imx-m4fwloader/imx-m4fwloader.mk [new file with mode: 0644]

index e1dbdfb3e2f43d5267f94ec955517476b1d2ac3c..b5e5ab23dc402d12052c1712e51124997afd7e03 100644 (file)
@@ -72,6 +72,7 @@ config BR2_PACKAGE_FREESCALE_IMX_HAS_VIV_GPU
 source "package/freescale-imx/imx-codec/Config.in"
 source "package/freescale-imx/imx-kobs/Config.in"
 source "package/freescale-imx/imx-lib/Config.in"
+source "package/freescale-imx/imx-m4fwloader/Config.in"
 source "package/freescale-imx/imx-parser/Config.in"
 source "package/freescale-imx/imx-uuc/Config.in"
 source "package/freescale-imx/imx-vpu/Config.in"
diff --git a/package/freescale-imx/imx-m4fwloader/Config.in b/package/freescale-imx/imx-m4fwloader/Config.in
new file mode 100644 (file)
index 0000000..937f82f
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_IMX_M4FWLOADER
+       bool "imx-m4fwloader"
+       depends on BR2_arm # Only relevant for i.MX
+       help
+         This package provides a tool to load a firmware to the
+         Cortex-M4 core available in some i.MX processors.
+
+         https://github.com/codeauroraforum/imx-m4fwloader
diff --git a/package/freescale-imx/imx-m4fwloader/imx-m4fwloader.hash b/package/freescale-imx/imx-m4fwloader/imx-m4fwloader.hash
new file mode 100644 (file)
index 0000000..2bf3f15
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed
+sha256 fb6334900972fe389e808845417dd9045fb0f7eb47952fc22a00f4cdaf94af1a  imx-m4fwloader-8cf4d17a09ba23250d43381b49ba00d92406fad9.tar.gz
+sha256 c03cea027b4b40e4402fabd08557736727ec3d5bc54ad64ab6472de432198cad  LICENSE
diff --git a/package/freescale-imx/imx-m4fwloader/imx-m4fwloader.mk b/package/freescale-imx/imx-m4fwloader/imx-m4fwloader.mk
new file mode 100644 (file)
index 0000000..cc48493
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# imx-m4fwloader
+#
+################################################################################
+
+IMX_M4FWLOADER_VERSION = 8cf4d17a09ba23250d43381b49ba00d92406fad9
+IMX_M4FWLOADER_SITE = $(call github,codeauroraforum,imx-m4fwloader,$(IMX_M4FWLOADER_VERSION))
+IMX_M4FWLOADER_LICENSE = GPL-2.0+
+IMX_M4FWLOADER_LICENSE_FILES = LICENSE
+
+define IMX_M4FWLOADER_BUILD_CMDS
+       $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) -o $(@D)/imx-m4fwloader \
+               $(@D)/m4fwloader.c
+endef
+
+define IMX_M4FWLOADER_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 755 $(@D)/imx-m4fwloader \
+               $(TARGET_DIR)/usr/sbin/imx-m4fwloader
+endef
+
+$(eval $(generic-package))