package/znc: set WANT_SWIG
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 15 Oct 2019 06:11:28 +0000 (08:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Oct 2019 10:32:25 +0000 (12:32 +0200)
Set WANT_SWIG={ON,OFF} to {en,dis}able swig and avoid a random build
failures probably due to parallel build issue when extracting
pre-generated tarball:

CMake Error: Problem with archive_write_header(): Can't unlink already-existing object
CMake Error: Current file: swigpyrun.h
CMake Error: Problem extracting tar: /usr/lfs/hdd_v1/rc-buildroot-test/scripts/instance-0/output/build/znc-1.7.5/modules/modpython/generated.tar.gz

This tarball contains pre-generated files, and is not used when
host-swig is available.

Fixes:
 - http://autobuild.buildroot.org/results/f3394de616cea4f474b6d5887aa0d5f5dff05281

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/znc/znc.mk

index 54dc63f4eaf00d3bb5e2fe0b432d1c44248b21dc..3932c980206faacd524023e745ceef5e248e8983 100644 (file)
@@ -42,9 +42,12 @@ ifeq ($(BR2_PACKAGE_ICU)$(BR2_PACKAGE_PYTHON3),yy)
 ZNC_DEPENDENCIES += python3 host-swig
 ZNC_CONF_OPTS += \
        -DWANT_PYTHON=ON \
-       -DWANT_PYTHON_VERSION=python3
+       -DWANT_PYTHON_VERSION=python3 \
+       -DWANT_SWIG=ON
 else
-ZNC_CONF_OPTS += -DWANT_PYTHON=OFF
+ZNC_CONF_OPTS += \
+       -DWANT_PYTHON=OFF \
+       -DWANT_SWIG=OFF
 endif
 
 $(eval $(cmake-package))