uboot-tools: fix build failure for the target
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 19 Jan 2013 01:04:43 +0000 (01:04 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 19 Jan 2013 18:23:45 +0000 (19:23 +0100)
The patch to drop config.h is still required, it just needed a tweak.
Fixes:
http://autobuild.buildroot.net/results/3653c0e3ec460c710524468987d5192337cf210e/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/uboot-tools/uboot-tools-drop-configh-from-tools.patch [new file with mode: 0644]

diff --git a/package/uboot-tools/uboot-tools-drop-configh-from-tools.patch b/package/uboot-tools/uboot-tools-drop-configh-from-tools.patch
new file mode 100644 (file)
index 0000000..21995ec
--- /dev/null
@@ -0,0 +1,37 @@
+We need to build u-boot tools without a board configuration for the target.
+fw_env just uses config.h to define the default environment of the created
+image, so it really isn't mandatory.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura u-boot-2013.01.orig/tools/env/fw_env.h u-boot-2013.01/tools/env/fw_env.h
+--- u-boot-2013.01.orig/tools/env/fw_env.h     2013-01-19 07:50:53.879241660 -0300
++++ u-boot-2013.01/tools/env/fw_env.h  2013-01-19 07:58:11.897903403 -0300
+@@ -21,15 +21,6 @@
+  * MA 02111-1307 USA
+  */
+-/* Pull in the current config to define the default environment */
+-#ifndef __ASSEMBLY__
+-#define __ASSEMBLY__ /* get only #defines from config.h */
+-#include <config.h>
+-#undef        __ASSEMBLY__
+-#else
+-#include <config.h>
+-#endif
+-
+ /*
+  * To build the utility with the static configuration
+  * comment out the next line.
+diff -Nura u-boot-2013.01.orig/tools/env/Makefile u-boot-2013.01/tools/env/Makefile
+--- u-boot-2013.01.orig/tools/env/Makefile     2013-01-19 07:50:53.879241660 -0300
++++ u-boot-2013.01/tools/env/Makefile  2013-01-19 07:59:34.926486346 -0300
+@@ -26,7 +26,7 @@
+ HOSTSRCS := $(SRCTREE)/lib/crc32.c  fw_env.c  fw_env_main.c
+ HOSTSRCS += $(SRCTREE)/lib/ctype.c $(SRCTREE)/lib/linux_string.c
+ HOSTSRCS += $(SRCTREE)/common/env_attr.c $(SRCTREE)/common/env_flags.c
+-HEADERS       := fw_env.h $(OBJTREE)/include/config.h
++HEADERS       := fw_env.h
+ # Compile for a hosted environment on the target
+ HOSTCPPFLAGS  = -idirafter $(SRCTREE)/include \