netsnmp: depend on openssl when the package is on to ensure build order
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 29 Jul 2010 12:15:17 +0000 (09:15 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 29 Jul 2010 12:25:45 +0000 (14:25 +0200)
The netsnmp package should depend on openssl when using it.
Otherwise netsnmp might get built before openssl and poison the
configure cache since it's not a mandatory dependency.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/netsnmp/netsnmp.mk

index 8f8bc76694c5f650215ec13f91ef1f548dcc510e..7c9367a087ef16f44680433860be2c6fb76c70d0 100644 (file)
@@ -28,6 +28,7 @@ endif
 
 # OpenSSL
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
+       NETSNMP_DEPENDENCIES += openssl
        NETSNMP_CONF_OPT += \
                --with-openssl=$(STAGING_DIR)/usr/include/openssl
 else