core/legal-info: generate a hash of all saved files
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 7 May 2016 16:14:36 +0000 (18:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 24 Jun 2016 14:56:50 +0000 (16:56 +0200)
Having a hash of the saved files can be interesting for the recipient to
verify the integrity of the files.

We remove the warning file earlier, to exclude it from the hash
list.

We generate the hash list in a temporary file that will not be matched
by the "find" expression, and once the file is generated, we remain it
to its final name.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Luca Ceresoli <luca@lucaceresoli.net>
Acked-by: Luca Ceresoli <luca@lucaceresoli.net>
Tested-by: Luca Ceresoli <luca@lucaceresoli.net>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
[Thomas: adjust indentation, improve commit log.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 78b44c5e4bcdcdc0fc3023ea0e675e37961688d0..41f02745a851294057cc3b9b9a9f55cd833caa3f 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -701,8 +701,12 @@ legal-info: dirs legal-info-clean legal-info-prepare $(foreach p,$(PACKAGES),$(p
                cat support/legal-info/README.warnings-header \
                        $(LEGAL_WARNINGS) >>$(LEGAL_REPORT); \
                cat $(LEGAL_WARNINGS); fi
-       @echo "Legal info produced in $(LEGAL_INFO_DIR)"
        @rm -f $(LEGAL_WARNINGS)
+       @(cd $(LEGAL_INFO_DIR); \
+               find * -type f -exec sha256sum {} + | LC_ALL=C sort -k2 \
+                       >.legal-info.sha256; \
+               mv .legal-info.sha256 legal-info.sha256)
+       @echo "Legal info produced in $(LEGAL_INFO_DIR)"
 
 show-targets:
        @echo $(PACKAGES) $(TARGETS_ROOTFS)