lmbench: fix build for xtensa
authorBaruch Siach <baruch@tkos.co.il>
Tue, 31 Dec 2013 09:07:30 +0000 (11:07 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 31 Dec 2013 10:57:51 +0000 (11:57 +0100)
The lmbench package generates a binary that is too large for the xtensa default
placement of literals in a dedicated section. Use -mtext-section-literal to
place literals in the text section.

Fixes
http://autobuild.buildroot.net/results/afe/afe9f4550e6ac9a41e4ba338773c1d51034273f7/.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lmbench/lmbench.mk

index c3a6c090d0bb27226767b52793750f884a1a8a40..529026fd72b9e25240e939a0d5c58be0637ae3b7 100644 (file)
@@ -19,6 +19,10 @@ LMBENCH_CFLAGS += -I$(STAGING_DIR)/usr/include/tirpc/
 LMBENCH_LDFLAGS += -ltirpc
 endif
 
+ifeq ($(BR2_xtensa),y)
+LMBENCH_CFLAGS += -mtext-section-literals
+endif
+
 define LMBENCH_CONFIGURE_CMDS
        $(call CONFIG_UPDATE,$(@D))
        sed -i 's/CFLAGS=/CFLAGS+=/g' $(@D)/src/Makefile