bind: fix compilation when lmdb.h is present on host
authorRobin Jarry <robin.jarry@6wind.com>
Fri, 8 Sep 2017 14:02:49 +0000 (16:02 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 9 Sep 2017 20:25:02 +0000 (22:25 +0200)
Bind autoconf scripts look for lmdb.h in /usr/include (even when
cross-compiling). When liblmdb-dev is installed, this causes the
following error:

    ...
    checking for lmdb library... yes
    checking for library containing mdb_env_create... no
    configure: error: found lmdb include but not library.

Fix this by disabling explicitly lmdb support.

Signed-off-by: Robin Jarry <robin.jarry@6wind.com>
Signed-off-by: Julien Floret <julien.floret@6wind.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bind/bind.mk

index c65568e9e3800740bbd844033167551797eae5ba..c3d48729deebbbe008f0f6ed5f4edba6d1e26f4c 100644 (file)
@@ -30,6 +30,7 @@ BIND_CONF_OPTS = \
        --enable-epoll \
        --with-libtool \
        --with-gssapi=no \
+       --with-lmdb=no \
        --enable-filter-aaaa
 
 ifeq ($(BR2_PACKAGE_ZLIB),y)