perl-io-interface: new package
authorChristopher McCrory <chrismcc@gmail.com>
Fri, 10 Aug 2018 16:14:54 +0000 (09:14 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Aug 2018 21:43:18 +0000 (23:43 +0200)
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
[Thomas: fix LICENSE variable.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/perl-io-interface/Config.in [new file with mode: 0644]
package/perl-io-interface/perl-io-interface.hash [new file with mode: 0644]
package/perl-io-interface/perl-io-interface.mk [new file with mode: 0644]

index 8348ce102f0460572bd8c1abe539c655dfc4e4e4..ed5ca129910964298ddee4874bce99ebc26ffe55 100644 (file)
@@ -489,6 +489,7 @@ F:  package/perl-date-manip/
 F:     package/perl-dbi/
 F:     package/perl-device-serialport/
 F:     package/perl-file-slurp/
+F:     package/perl-io-interface/
 
 N:     Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
 F:     package/audit/
index ba5b0e1699219f63fc1d91ed9e5eb3987c19cb17..ac145b3a0f3ab331a219997f3b08ab6a1b1030be 100644 (file)
@@ -697,6 +697,7 @@ menu "Perl libraries/modules"
        source "package/perl-http-message/Config.in"
        source "package/perl-http-negotiate/Config.in"
        source "package/perl-io-html/Config.in"
+       source "package/perl-io-interface/Config.in"
        source "package/perl-io-socket-ssl/Config.in"
        source "package/perl-json-tiny/Config.in"
        source "package/perl-libwww-perl/Config.in"
diff --git a/package/perl-io-interface/Config.in b/package/perl-io-interface/Config.in
new file mode 100644 (file)
index 0000000..7aa7064
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PERL_IO_INTERFACE
+       bool "perl-io-interface"
+       depends on !BR2_STATIC_LIBS
+       help
+         Access and modify network interface card configuration
+
+         https://metacpan.org/release/IO-Interface
+
+comment "perl-io-interface needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
diff --git a/package/perl-io-interface/perl-io-interface.hash b/package/perl-io-interface/perl-io-interface.hash
new file mode 100644 (file)
index 0000000..75e572f
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    806f97aff5a7361b6f54cd494f4cc9fd IO-Interface-1.09.tar.gz
+sha256 e63e81c52eb1e0e60ec2d983f5552d2493e117179925c96757f23c4bd9fa713a IO-Interface-1.09.tar.gz
+
+# computed by scancpan
+sha256 b5a5bf59bd1be13f7f498e5aa2ea5c0c603c04a095dcf03a06aa5b83bbccf921 LICENSE
diff --git a/package/perl-io-interface/perl-io-interface.mk b/package/perl-io-interface/perl-io-interface.mk
new file mode 100644 (file)
index 0000000..c0b399a
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-io-interface
+#
+################################################################################
+
+PERL_IO_INTERFACE_VERSION = 1.09
+PERL_IO_INTERFACE_SOURCE = IO-Interface-$(PERL_IO_INTERFACE_VERSION).tar.gz
+PERL_IO_INTERFACE_SITE = $(BR2_CPAN_MIRROR)/authors/id/L/LD/LDS
+PERL_IO_INTERFACE_DEPENDENCIES = host-perl-module-build
+PERL_IO_INTERFACE_LICENSE = Artistic-2.0
+PERL_IO_INTERFACE_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))