lighttpd: Add systemd tmpfile to fix lighttpd systemd boot
authorLaurent Hartanerot <laurent.hartanerot@atos.net>
Mon, 30 Jul 2018 10:24:16 +0000 (12:24 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 14 Aug 2018 14:27:58 +0000 (16:27 +0200)
Problem starting lighttpd application with systemd.

/usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf
2018-06-22 11:21:34: (server.c.733) opening errorlog '/var/log/lighttpd-error.log' failed: Permission denied
2018-06-22 11:21:34: (server.c.1420) Opening errorlog failed. Going down.

Lighttpd can not write the 'lighttpd-access.log' and 'lighttpd-error.log' files
to the directory '/var/log/'.

When using systemd the directory '/var/log' does not allow the user www-data to
write.

To correct the problem, we add /usr/lib/tmpfiles.d/lighttpd.conf.
This file create the 'lighttpd-access.log' and 'lighttpd-error.log' files  with
the permission

Signed-off-by: Laurent Hartanerot <laurent.hartanerot@atos.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lighttpd/lighttpd.mk
package/lighttpd/lighttpd_tmpfiles.conf [new file with mode: 0644]

index c565fed4ff4723cf384cf22281809b1219e67fde..06561e9f55af477c43b2babcadd45e6949d3e1ab 100644 (file)
@@ -96,6 +96,9 @@ define LIGHTTPD_INSTALL_INIT_SYSTEMD
 
        ln -fs ../../../../usr/lib/systemd/system/lighttpd.service \
                $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants/lighttpd.service
+
+       $(INSTALL) -D -m 644 package/lighttpd/lighttpd_tmpfiles.conf \
+               $(TARGET_DIR)/usr/lib/tmpfiles.d/lighttpd.conf
 endef
 
 $(eval $(autotools-package))
diff --git a/package/lighttpd/lighttpd_tmpfiles.conf b/package/lighttpd/lighttpd_tmpfiles.conf
new file mode 100644 (file)
index 0000000..a24f3f7
--- /dev/null
@@ -0,0 +1,2 @@
+f /var/log/lighttpd-access.log 0640 www-data www-data -
+f /var/log/lighttpd-error.log 0640 www-data www-data -