boost: reorder build steps
authorPeter Korsgaard <peter@korsgaard.com>
Sat, 5 Dec 2015 14:05:32 +0000 (15:05 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 5 Dec 2015 14:38:05 +0000 (15:38 +0100)
The host and target build steps were mixed between eachother. Reorder them
so we have the target steps before the host ones.

No functional change, but helps readability.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/boost/boost.mk

index 36710f73391e08974411f15ef467080c6dc50a9b..b96969d66294971799c5e08849900b5a705b52ac 100644 (file)
@@ -128,12 +128,6 @@ define BOOST_CONFIGURE_CMDS
        echo "" >> $(@D)/user-config.jam
 endef
 
-define HOST_BOOST_CONFIGURE_CMDS
-       (cd $(@D) && ./bootstrap.sh $(HOST_BOOST_FLAGS))
-       echo "using gcc : `$(HOST_CC) -dumpversion` : $(HOSTCXX) : <cxxflags>\"$(HOST_CXXFLAGS)\" <linkflags>\"$(HOST_LDFLAGS)\" ;" > $(@D)/user-config.jam
-       echo "" >> $(@D)/user-config.jam
-endef
-
 define BOOST_INSTALL_TARGET_CMDS
        (cd $(@D) && ./b2 -j$(PARALLEL_JOBS) -q \
        --user-config=$(@D)/user-config.jam \
@@ -143,6 +137,21 @@ define BOOST_INSTALL_TARGET_CMDS
        --layout=$(BOOST_LAYOUT) install )
 endef
 
+define BOOST_INSTALL_STAGING_CMDS
+       (cd $(@D) && ./bjam -j$(PARALLEL_JOBS) -q \
+       --user-config=$(@D)/user-config.jam \
+       $(BOOST_OPTS) \
+       --prefix=$(STAGING_DIR)/usr \
+       --ignore-site-config \
+       --layout=$(BOOST_LAYOUT) install)
+endef
+
+define HOST_BOOST_CONFIGURE_CMDS
+       (cd $(@D) && ./bootstrap.sh $(HOST_BOOST_FLAGS))
+       echo "using gcc : `$(HOST_CC) -dumpversion` : $(HOSTCXX) : <cxxflags>\"$(HOST_CXXFLAGS)\" <linkflags>\"$(HOST_LDFLAGS)\" ;" > $(@D)/user-config.jam
+       echo "" >> $(@D)/user-config.jam
+endef
+
 define HOST_BOOST_BUILD_CMDS
        (cd $(@D) && ./b2 -j$(PARALLEL_JOBS) -q \
        --user-config=$(@D)/user-config.jam \
@@ -160,14 +169,5 @@ define HOST_BOOST_INSTALL_CMDS
        --layout=$(BOOST_LAYOUT) install )
 endef
 
-define BOOST_INSTALL_STAGING_CMDS
-       (cd $(@D) && ./bjam -j$(PARALLEL_JOBS) -q \
-       --user-config=$(@D)/user-config.jam \
-       $(BOOST_OPTS) \
-       --prefix=$(STAGING_DIR)/usr \
-       --ignore-site-config \
-       --layout=$(BOOST_LAYOUT) install)
-endef
-
 $(eval $(generic-package))
 $(eval $(host-generic-package))