fs: squashfs: Add config option to pass nopad parameter to mksquashfs
authorChristoph Muellner <christoph.muellner@theobroma-systems.com>
Sun, 14 Jun 2020 22:41:43 +0000 (00:41 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Wed, 17 Jun 2020 21:01:23 +0000 (23:01 +0200)
Add an option to enable/disable padding to a multiple of 4k. Padding is
the default as it also was the past default behaviour.

Signed-off-by: Christoph Muellner <christoph.muellner@theobroma-systems.com>
Signed-off-by: Heiko Stuebner <heiko.stuebner@theobroma-systems.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
fs/squashfs/Config.in
fs/squashfs/squashfs.mk

index dde2097cb747f7c0b42969635da775d1b8156afe..70d4a20cf0528a42928cafd3f6e93fd96a57d140 100644 (file)
@@ -5,6 +5,13 @@ config BR2_TARGET_ROOTFS_SQUASHFS
 
 if BR2_TARGET_ROOTFS_SQUASHFS
 
+config BR2_TARGET_ROOTFS_SQUASHFS_PAD
+       bool "pad to a 4K boundary"
+       default y # legacy was always ON
+       help
+         Say 'y' here (the default) to pad the the filesystem image
+         to a 4K boundary. Say 'n' to disable padding.
+
 choice
        prompt "Compression algorithm"
        default BR2_TARGET_ROOTFS_SQUASHFS4_GZIP
@@ -31,4 +38,5 @@ config BR2_TARGET_ROOTFS_SQUASHFS4_ZSTD
        bool "zstd"
 
 endchoice
+
 endif
index 34ab0486036f53ac1bebf58fe8ff50ac196a5305..7a5e3e313ee7a4187c73eaf2ca0852251f268f30 100644 (file)
@@ -8,6 +8,10 @@ ROOTFS_SQUASHFS_DEPENDENCIES = host-squashfs
 
 ROOTFS_SQUASHFS_ARGS = -noappend -processors $(PARALLEL_JOBS)
 
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS_PAD),)
+ROOTFS_SQUASHFS_ARGS += -nopad
+endif
+
 ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZ4),y)
 ROOTFS_SQUASHFS_ARGS += -comp lz4 -Xhc
 else ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS4_LZO),y)