module-init-tools: bump to version 3.15
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 10 Nov 2011 11:25:25 +0000 (08:25 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 11 Nov 2011 20:41:21 +0000 (21:41 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/module-init-tools/module-init-tools-3.11-add-manpages-config-option.patch [deleted file]
package/module-init-tools/module-init-tools-3.15-add-manpages-config-option.patch [new file with mode: 0644]
package/module-init-tools/module-init-tools.mk

diff --git a/package/module-init-tools/module-init-tools-3.11-add-manpages-config-option.patch b/package/module-init-tools/module-init-tools-3.11-add-manpages-config-option.patch
deleted file mode 100644 (file)
index 28f51de..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-Disable manual pages generation when docbook2man is not available.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- Makefile.am  |    7 ++++++-
- configure.ac |    7 +++----
- 2 files changed, 9 insertions(+), 5 deletions(-)
-
-Index: module-init-tools-3.11/Makefile.am
-===================================================================
---- module-init-tools-3.11.orig/Makefile.am
-+++ module-init-tools-3.11/Makefile.am
-@@ -39,7 +39,12 @@
- MAN5 = modprobe.conf.5 modules.dep.5 depmod.conf.5 modprobe.d.5
- MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8
- SGML = $(addprefix doc/,  $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml))
--dist_man_MANS = $(MAN5) $(MAN8)
-+
-+if HAVE_DOCBOOKTOMAN
-+MANPAGES  = $(MAN5) $(MAN8)
-+endif
-+dist_man_MANS = $(MANPAGES)
-+
- # If they haven't overridden mandir, fix it (never /man!)
- mandir =$(shell if [ @mandir@ = $(prefix)/man ]; then if [ $(prefix) = / ]; then echo /usr/share/man; else echo $(prefix)/share/man; fi; else echo @mandir@; fi)
-Index: module-init-tools-3.11/configure.ac
-===================================================================
---- module-init-tools-3.11.orig/configure.ac
-+++ module-init-tools-3.11/configure.ac
-@@ -29,13 +29,12 @@
- AC_PROG_CC
- AC_PROG_RANLIB
--AC_CHECK_PROGS(DOCBOOKTOMAN, docbook-to-man docbook2man, [no],)
--if test x"$DOCBOOKTOMAN" = xno
-+AC_CHECK_PROGS(DOCBOOKTOMAN, docbook-to-man docbook2man)
-+if test x"$DOCBOOKTOMAN" = x
- then
-       AC_MSG_WARN([docbook2man not found])
--      # fail with a meaningfull error if $DOCBOOKTOMAN called by the makefile
--      DOCBOOKTOMAN=docbook2man
- fi
-+AM_CONDITIONAL([HAVE_DOCBOOKTOMAN], [test "x$DOCBOOKTOMAN" != "x"])
-  
- # Delay adding the zlib_flags until after AC_PROG_CC, so we can distinguish
- # between a broken cc and a working cc but missing libz.a.
diff --git a/package/module-init-tools/module-init-tools-3.15-add-manpages-config-option.patch b/package/module-init-tools/module-init-tools-3.15-add-manpages-config-option.patch
new file mode 100644 (file)
index 0000000..28f51de
--- /dev/null
@@ -0,0 +1,47 @@
+Disable manual pages generation when docbook2man is not available.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+---
+ Makefile.am  |    7 ++++++-
+ configure.ac |    7 +++----
+ 2 files changed, 9 insertions(+), 5 deletions(-)
+
+Index: module-init-tools-3.11/Makefile.am
+===================================================================
+--- module-init-tools-3.11.orig/Makefile.am
++++ module-init-tools-3.11/Makefile.am
+@@ -39,7 +39,12 @@
+ MAN5 = modprobe.conf.5 modules.dep.5 depmod.conf.5 modprobe.d.5
+ MAN8 = depmod.8 insmod.8 lsmod.8 rmmod.8 modprobe.8 modinfo.8
+ SGML = $(addprefix doc/,  $(MAN5:%.5=%.sgml) $(MAN8:%.8=%.sgml))
+-dist_man_MANS = $(MAN5) $(MAN8)
++
++if HAVE_DOCBOOKTOMAN
++MANPAGES  = $(MAN5) $(MAN8)
++endif
++dist_man_MANS = $(MANPAGES)
++
+ # If they haven't overridden mandir, fix it (never /man!)
+ mandir =$(shell if [ @mandir@ = $(prefix)/man ]; then if [ $(prefix) = / ]; then echo /usr/share/man; else echo $(prefix)/share/man; fi; else echo @mandir@; fi)
+Index: module-init-tools-3.11/configure.ac
+===================================================================
+--- module-init-tools-3.11.orig/configure.ac
++++ module-init-tools-3.11/configure.ac
+@@ -29,13 +29,12 @@
+ AC_PROG_CC
+ AC_PROG_RANLIB
+-AC_CHECK_PROGS(DOCBOOKTOMAN, docbook-to-man docbook2man, [no],)
+-if test x"$DOCBOOKTOMAN" = xno
++AC_CHECK_PROGS(DOCBOOKTOMAN, docbook-to-man docbook2man)
++if test x"$DOCBOOKTOMAN" = x
+ then
+       AC_MSG_WARN([docbook2man not found])
+-      # fail with a meaningfull error if $DOCBOOKTOMAN called by the makefile
+-      DOCBOOKTOMAN=docbook2man
+ fi
++AM_CONDITIONAL([HAVE_DOCBOOKTOMAN], [test "x$DOCBOOKTOMAN" != "x"])
+  
+ # Delay adding the zlib_flags until after AC_PROG_CC, so we can distinguish
+ # between a broken cc and a working cc but missing libz.a.
index d7e7c2401904ace6f9369be422e7872b564d5a7a..ad92a1ac91d5ad94423eaa35a18015568e87332c 100644 (file)
@@ -3,19 +3,20 @@
 # module-init-tools
 #
 #############################################################
-MODULE_INIT_TOOLS_VERSION=3.12
-MODULE_INIT_TOOLS_SOURCE=module-init-tools-$(MODULE_INIT_TOOLS_VERSION).tar.bz2
-MODULE_INIT_TOOLS_SITE=$(BR2_KERNEL_MIRROR)/linux/utils/kernel/module-init-tools/
+
+MODULE_INIT_TOOLS_VERSION = 3.15
+MODULE_INIT_TOOLS_SOURCE = module-init-tools-$(MODULE_INIT_TOOLS_VERSION).tar.bz2
+MODULE_INIT_TOOLS_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/kernel/module-init-tools/
 MODULE_INIT_TOOLS_CONF_ENV = ac_cv_prog_DOCBOOKTOMAN=''
 MODULE_INIT_TOOLS_CONF_OPT = \
        --disable-static-utils \
        --disable-builddir \
        --program-transform-name=''
 
-# module-init-tools-3.11-add-manpages-config-option.patch is modifying
+# module-init-tools-3.15-add-manpages-config-option.patch is modifying
 # configure.ac and Makefile.am
-MODULE_INIT_TOOLS_AUTORECONF=YES
-HOST_MODULE_INIT_TOOLS_AUTORECONF=YES
+MODULE_INIT_TOOLS_AUTORECONF = YES
+HOST_MODULE_INIT_TOOLS_AUTORECONF = YES
 HOST_MODULE_INIT_TOOLS_CONF_ENV = ac_cv_prog_DOCBOOKTOMAN=''
 
 $(eval $(call AUTOTARGETS))