toolchain/gcc: the ARC version of gcc needs host-flex/host-bison
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 9 May 2013 05:53:05 +0000 (05:53 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 12 May 2013 20:22:18 +0000 (22:22 +0200)
For some reason (probably because the ARC changes modify some lex/yacc
files without updating their pre-generated variants, or because the
date/time of the pre-generated files is not correct), building the ARC
gcc requires host-flex and host-bison.

We have tested 4.2 for AVR, 4.3 and 4.4 for ARM, and none of those
need host-flex or host-bison to be installed, so only the 4.4 for ARC
seems to be affected.

Fixes the build failure visible at
http://autobuild.buildroot.org/results/673c6262e3dde8ee8dd28204d814097e6ba8f8e9/build-end.log.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/gcc/gcc-uclibc-4.x.mk

index 8cacc32817d631882e7902104078c8ac3711ee05..21679ef17f710f4f51c03c601e260b5c3cafad59 100644 (file)
@@ -180,6 +180,10 @@ endif
 GCC_HOST_PREREQ += host-mpc
 endif
 
+ifeq ($(BR2_GCC_VERSION_4_4_7_ARC),y)
+GCC_HOST_PREREQ += host-flex host-bison
+endif
+
 ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
 GCC_SHARED_LIBGCC:=--enable-shared
 else