package/perl-crypt-openssl-rsa: add missing dependency to openssl
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 12 Jun 2021 21:32:03 +0000 (23:32 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 12 Jun 2021 21:32:03 +0000 (23:32 +0200)
perl-crypt-openssl-rsa inherits the dependency on openssl indirectly
from perl-crypt-openssl-random. Hwvere, perl-crypt-openssl-rsa needs
the openssl libraries for itself, so it must explicitly depend on it.

So far, this was totally unconsequential, but since commit a83d41867c8d
(package/libopenssl: add option to enable some features), features can
be configured out, of which RMD160 that perl-crypt-openssl-rsa needs.
If we were to add the select to that option (in a followup commit),
without a dependency to openssl, that would be very confusing in the
future.

So, add the explicit dependency now.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/perl-crypt-openssl-rsa/Config.in
package/perl-crypt-openssl-rsa/perl-crypt-openssl-rsa.mk

index e58a921bcb719d41216f7913f76f8d292abb595c..e2c0131345ee218eab36f78c640c06b98b2a0536 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_PACKAGE_PERL_CRYPT_OPENSSL_RSA
        bool "perl-crypt-openssl-rsa"
        depends on !BR2_STATIC_LIBS
+       select BR2_PACKAGE_OPENSSL
        select BR2_PACKAGE_PERL_CRYPT_OPENSSL_RANDOM # runtime
        help
          RSA encoding and decoding, using the openSSL libraries.
index b161523421f16a3a88bdb8dec1b0ed81b8cc12f4..23fd1ac3811983ef51cfa87fca98f6e6a88a23ce 100644 (file)
@@ -9,7 +9,8 @@ PERL_CRYPT_OPENSSL_RSA_SOURCE = Crypt-OpenSSL-RSA-$(PERL_CRYPT_OPENSSL_RSA_VERSI
 PERL_CRYPT_OPENSSL_RSA_SITE = $(BR2_CPAN_MIRROR)/authors/id/T/TO/TODDR
 PERL_CRYPT_OPENSSL_RSA_DEPENDENCIES = \
        host-perl-crypt-openssl-guess \
-       perl-crypt-openssl-random
+       perl-crypt-openssl-random \
+       openssl
 PERL_CRYPT_OPENSSL_RSA_LICENSE = Artistic or GPL-1.0+
 PERL_CRYPT_OPENSSL_RSA_LICENSE_FILES = LICENSE
 PERL_CRYPT_OPENSSL_RSA_DISTNAME = Crypt-OpenSSL-RSA