package/chartjs: new package
authorJoeri Barbarien <joeri.barbarien@nokia.com>
Mon, 10 Feb 2020 11:26:30 +0000 (12:26 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 15 Mar 2020 20:38:56 +0000 (21:38 +0100)
Note: even though the Chart.js developers make specific tarballs on GitHub
(i.e. not simply 'source code' tarballs), they cannot be used in Buildroot
because their names do not encode a version number, e.g. 'Chart.js.zip'.
This means that on upgrades, the same tarball name would have different
contents and thus a different hash.

Signed-off-by: Joeri Barbarien <joeri.barbarien@nokia.com>
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/chartjs/Config.in [new file with mode: 0644]
package/chartjs/chartjs.hash [new file with mode: 0644]
package/chartjs/chartjs.mk [new file with mode: 0644]

index a8ed03488da51737dd581ae3e42e1a424de58568..dfc0dc6a6c91b6e572dd36724e7b195ac02e8b49 100644 (file)
@@ -2394,6 +2394,7 @@ F:        package/civetweb/
 N:     Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
 F:     docs/manual/
 F:     package/cereal/
+F:     package/chartjs/
 F:     package/libtelnet/
 F:     package/opkg-utils/
 F:     package/perl-convert-asn1/
index dafc75540d7494cfe0677c304c0b503e217a7f14..e35250808dae61d2af8bba68e47e55976fbc49d1 100644 (file)
@@ -1515,6 +1515,7 @@ menu "External AngularJS plugins"
 endmenu
 endif
        source "package/bootstrap/Config.in"
+       source "package/chartjs/Config.in"
        source "package/duktape/Config.in"
        source "package/explorercanvas/Config.in"
        source "package/flot/Config.in"
diff --git a/package/chartjs/Config.in b/package/chartjs/Config.in
new file mode 100644 (file)
index 0000000..73cc9b7
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_CHARTJS
+       bool "chartjs"
+       help
+         Chart.js, a simple yet flexible JavaScript charting library
+         for designers & developers
+
+         https://www.chartjs.org/
diff --git a/package/chartjs/chartjs.hash b/package/chartjs/chartjs.hash
new file mode 100644 (file)
index 0000000..d2426ea
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed:
+sha256 8079d8fd39131fcfaec33f1c7799412bcf8e051e25b10bd6e37fc16159417aa1  chartjs-v2.9.3.tar.gz
+sha256 7b43caae91f31b18dc81fae6e0f7aa1acbecaa6d84e3249905cbe15308307d67  LICENSE.md
diff --git a/package/chartjs/chartjs.mk b/package/chartjs/chartjs.mk
new file mode 100644 (file)
index 0000000..171e0a4
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# chartjs
+#
+################################################################################
+
+CHARTJS_VERSION = v2.9.3
+CHARTJS_SITE = $(call github,chartjs,Chart.js,$(CHARTJS_VERSION))
+CHARTJS_LICENSE = MIT
+CHARTJS_LICENSE_FILES = LICENSE.md
+
+define CHARTJS_INSTALL_TARGET_CMDS
+       $(INSTALL) -m 0644 -D $(@D)/dist/Chart.min.css \
+               $(TARGET_DIR)/var/www/chartjs/css/Chart.css
+       $(INSTALL) -m 0644 -D $(@D)/dist/Chart.min.js \
+               $(TARGET_DIR)/var/www/chartjs/js/Chart.js
+       $(INSTALL) -m 0644 -D $(@D)/dist/Chart.bundle.min.js \
+               $(TARGET_DIR)/var/www/chartjs/js/Chart.bundle.js
+endef
+
+$(eval $(generic-package))